Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725284 - sci-astronomy/weightwatcher calls ar directly
Summary: sci-astronomy/weightwatcher calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci Astronomy Herd
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-25 10:10 UTC by Agostino Sarubbo
Modified: 2021-01-02 20:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.36 KB, text/plain)
2020-05-25 10:10 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-25 10:10:13 UTC
This is an auto-filed bug because sci-astronomy/weightwatcher calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-25 10:10:18 UTC
Created attachment 641686 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-01-02 20:16:48 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c66f73c85e12f55cbc2ca4da527101ae3b89b27b

commit c66f73c85e12f55cbc2ca4da527101ae3b89b27b
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-01-02 20:16:32 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-01-02 20:16:32 +0000

    sci-astronomy/weightwatcher: Port to EAPI 7
    
    * Fix direct AR call
    * Fix build with gcc-10
    
    Closes: https://bugs.gentoo.org/707594
    Closes: https://bugs.gentoo.org/725284
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../files/weightwatcher-1.12-AR.patch              |  11 ++
 .../files/weightwatcher-1.12-fno-common.patch      | 160 +++++++++++++++++++++
 .../weightwatcher/weightwatcher-1.12.ebuild        |  17 ++-
 3 files changed, 184 insertions(+), 4 deletions(-)