Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725274 - sci-astronomy/swarp calls ar directly
Summary: sci-astronomy/swarp calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci Astronomy Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-25 10:09 UTC by Agostino Sarubbo
Modified: 2021-02-14 10:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,47.72 KB, text/plain)
2020-05-25 10:09 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-25 10:09:00 UTC
This is an auto-filed bug because sci-astronomy/swarp calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-25 10:09:05 UTC
Created attachment 641676 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-02-14 10:36:43 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73

commit d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-02-14 10:33:00 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-02-14 10:33:00 +0000

    sci-astronomy/swarp: Bump to 2.41.5
    
    * Fixes gcc-10 issues and AR call
    
    Closes: https://bugs.gentoo.org/707856
    Closes: https://bugs.gentoo.org/725274
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: David Seifert <soap@gentoo.org>

 sci-astronomy/swarp/Manifest            |  1 +
 sci-astronomy/swarp/metadata.xml        |  3 +++
 sci-astronomy/swarp/swarp-2.41.5.ebuild | 34 +++++++++++++++++++++++++++++++++
 3 files changed, 38 insertions(+)