Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724966 - net-irc/iroffer-dinoex calls cc directly
Summary: net-irc/iroffer-dinoex calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-24 08:14 UTC by Agostino Sarubbo
Modified: 2020-05-24 09:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.57 KB, text/plain)
2020-05-24 08:14 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-24 08:14:15 UTC
This is an auto-filed bug because net-irc/iroffer-dinoex calls cc directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different CC implementation (like clang) by setting the CC variable. So this issue has been reproduced by setting the CC variable to x86_64-pc-linux-gnu-gcc and by removing the /usr/bin/cc - /usr/bin/gcc binaries.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-24 08:14:21 UTC
Created attachment 641332 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-05-24 09:31:20 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c32effab9e41d89e9137a6b5b797eed65c4119a2

commit c32effab9e41d89e9137a6b5b797eed65c4119a2
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2020-05-24 09:30:50 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2020-05-24 09:31:14 +0000

    net-irc/iroffer-dinoex: respect CC
    
    Closes: https://bugs.gentoo.org/724966
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 net-irc/iroffer-dinoex/iroffer-dinoex-3.30-r1.ebuild | 3 ++-
 net-irc/iroffer-dinoex/iroffer-dinoex-3.31.ebuild    | 3 ++-
 net-irc/iroffer-dinoex/iroffer-dinoex-3.32.ebuild    | 5 +++--
 3 files changed, 7 insertions(+), 4 deletions(-)