Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724864 - net-analyzer/hunt does not respect CFLAGS
Summary: net-analyzer/hunt does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2020-05-23 19:47 UTC by Agostino Sarubbo
Modified: 2021-05-04 22:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,96.19 KB, text/plain)
2020-05-23 19:47 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-23 19:47:01 UTC
This is an auto-filed bug because net-analyzer/hunt does not respect CFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-23 19:47:06 UTC
Created attachment 641254 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-05-04 22:17:44 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b6346d471e739bc4def7dc86a2e25e15de45e49a

commit b6346d471e739bc4def7dc86a2e25e15de45e49a
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-04-29 23:49:38 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-05-04 22:17:09 +0000

    net-analyzer/hunt: Respect CFLAGS
    
    Closes: https://bugs.gentoo.org/724864
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: Sam James <sam@gentoo.org>

 net-analyzer/hunt/files/hunt-1.5-gentoo.patch |  5 ++++-
 net-analyzer/hunt/hunt-1.5_p6_p1.ebuild       | 17 +++++++----------
 2 files changed, 11 insertions(+), 11 deletions(-)