Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724716 - mail-client/neomutt calls cc directly
Summary: mail-client/neomutt calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Nicolas Bock
URL:
Whiteboard:
Keywords: PullRequest
: 728980 730202 (view as bug list)
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-23 13:17 UTC by Agostino Sarubbo
Modified: 2021-05-14 00:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,71.45 KB, text/plain)
2020-05-23 13:17 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-23 13:17:11 UTC
This is an auto-filed bug because mail-client/neomutt calls cc directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different CC implementation (like clang) by setting the CC variable. So this issue has been reproduced by setting the CC variable to x86_64-pc-linux-gnu-gcc and by removing the /usr/bin/cc - /usr/bin/gcc binaries.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-23 13:17:18 UTC
Created attachment 641092 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-07-05 07:52:08 UTC
*** Bug 728980 has been marked as a duplicate of this bug. ***
Comment 3 Nicolas Bock gentoo-dev 2020-08-25 19:28:29 UTC
I cannot reproduce with neomutt-20200626:

CC=gurke ebuild neomutt-20200626-r1.ebuild configure

produces

Error: Could not find a C compiler. Tried: gurke
Comment 4 Agostino Sarubbo gentoo-dev 2020-08-25 20:15:01 UTC
please try full merge with x86_64-pc-linux-gnu-gcc as CC
Comment 5 Sam James archtester gentoo-dev Security 2020-08-25 20:35:36 UTC
(In reply to Agostino Sarubbo from comment #4)
> please try full merge with x86_64-pc-linux-gnu-gcc as CC

I think the issue is that it calls the correct tuple MOSTLY (via CC), but if USE=docs, it makes a few calls to 'gcc'.

So that needs fixing.
Comment 6 Sam James archtester gentoo-dev Security 2020-08-25 21:05:01 UTC
*** Bug 730202 has been marked as a duplicate of this bug. ***
Comment 7 Nicolas Bock gentoo-dev 2021-05-13 18:29:45 UTC
Sam,

Please have a look at https://github.com/gentoo/gentoo/pull/20796. That fixes this issue in my local tests.

Thanks,

Nick
Comment 8 Larry the Git Cow gentoo-dev 2021-05-14 00:22:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=12abfe9e49c4d244e9d4e237f1329356880e1bdf

commit 12abfe9e49c4d244e9d4e237f1329356880e1bdf
Author:     Nicolas Bock <nicolasbock@gentoo.org>
AuthorDate: 2021-05-13 18:26:24 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-05-14 00:22:38 +0000

    mail-client/neomutt: Do not call `cc`
    
    Closes: https://bugs.gentoo.org/724716
    Closes: https://github.com/gentoo/gentoo/pull/20796
    Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
    Signed-off-by: Sam James <sam@gentoo.org>

 mail-client/neomutt/neomutt-20210205-r1.ebuild | 4 +++-
 mail-client/neomutt/neomutt-99999999.ebuild    | 4 +++-
 2 files changed, 6 insertions(+), 2 deletions(-)
Comment 9 Sam James archtester gentoo-dev Security 2021-05-14 00:23:46 UTC
(In reply to Nicolas Bock from comment #7)
> Sam,
> 
> Please have a look at https://github.com/gentoo/gentoo/pull/20796. That
> fixes this issue in my local tests.
> 
> Thanks,
> 
> Nick

Thanks!