Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 723996 - dev-python/pytest-5.4.3 ppc stabilisation
Summary: dev-python/pytest-5.4.3 ppc stabilisation
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: CC-ARCHES
Depends on: 731986
Blocks: 723994 725890 726358 727058 730372 731528
  Show dependency tree
 
Reported: 2020-05-19 16:04 UTC by Andreas Sturmlechner
Modified: 2020-07-11 07:59 UTC (History)
1 user (show)

See Also:
Package list:
dev-python/xmlschema-1.1.3 dev-python/elementpath-1.4.5 dev-python/pytest-5.4.3
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2020-05-19 16:04:05 UTC
Please add arches if ready. Though I imagine there might be python target conflicts ahead considering this version drops py27 support.
Comment 1 NATTkA bot gentoo-dev 2020-05-23 13:48:39 UTC
Sanity check failed:

> dev-python/pytest-5.4.2
>   depend amd64 stable profile default/linux/amd64/17.0 (57 total)
>     dev-python/xmlschema[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-),python_targets_python3_7(-)]
>   depend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (33 total)
>     dev-python/xmlschema[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-),python_targets_python3_7(-)]
>   depend hppa stable profile default/linux/hppa/17.0 (3 total)
>     dev-python/xmlschema[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-)]
Comment 2 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-05-23 13:57:20 UTC
(In reply to Andreas Sturmlechner from comment #0)
> Please add arches if ready. Though I imagine there might be python target
> conflicts ahead considering this version drops py27 support.

That's why I didn't request stabilization yet.  Is there any (to-be)-stable package requiring this?
Comment 3 NATTkA bot gentoo-dev 2020-05-23 14:00:49 UTC
Resetting sanity check; keywords are not fully specified and arches are not CC-ed.
Comment 4 Andreas Sturmlechner gentoo-dev 2020-05-23 14:13:18 UTC
(In reply to Michał Górny from comment #2)
> That's why I didn't request stabilization yet.  Is there any (to-be)-stable
> package requiring this?

That would be the dependent bug, yes, unless we find a different solution for it.
Comment 5 NATTkA bot gentoo-dev 2020-05-26 11:16:46 UTC
Sanity check failed:

> dev-python/xmlschema-1.1.3
>   bdepend amd64 stable profile default/linux/amd64/17.0 (57 total)
>     =dev-python/elementpath-1.4*[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-),python_targets_python3_7(-)]
>   bdepend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (33 total)
>     =dev-python/elementpath-1.4*[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-),python_targets_python3_7(-)]
>   rdepend amd64 stable profile default/linux/amd64/17.0 (57 total)
>     =dev-python/elementpath-1.4*[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-),python_targets_python3_7(-)]
>   rdepend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (33 total)
>     =dev-python/elementpath-1.4*[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-),python_targets_python3_7(-)]
>   bdepend hppa stable profile default/linux/hppa/17.0 (3 total)
>     =dev-python/elementpath-1.4*[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-)]
>   rdepend hppa stable profile default/linux/hppa/17.0 (3 total)
>     =dev-python/elementpath-1.4*[-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),python_targets_python3_6(-)]
Comment 6 NATTkA bot gentoo-dev 2020-05-26 11:20:44 UTC
All sanity-check issues have been resolved
Comment 7 Rolf Eike Beer archtester 2020-05-27 19:11:53 UTC
hppa stable
Comment 8 Rolf Eike Beer archtester 2020-05-28 18:23:06 UTC
sparc stable
Comment 9 Sam James archtester gentoo-dev Security 2020-05-30 19:59:38 UTC
arm64 stable
Comment 10 Sam James archtester gentoo-dev Security 2020-06-06 18:06:33 UTC
arm stable
Comment 11 ernsteiswuerfel archtester 2020-06-09 15:26:14 UTC
dev-python/xmlschema-1.1.3 is not ~ppc/~ppc64 keyworded, only xmlschema-1.2.0.
Comment 12 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-06-09 16:26:47 UTC
(In reply to ernsteiswuerfel from comment #11)
> dev-python/xmlschema-1.1.3 is not ~ppc/~ppc64 keyworded, only
> xmlschema-1.2.0.

Take it straight to stable, I guess.
Comment 13 ernsteiswuerfel archtester 2020-06-14 17:38:49 UTC
On ppc tests fail (bug # 728266) and rdeps pytest-cov (bug # 728268), pytest-forked (bug # 728270). Rest looks good.

# cat pytest-723996.report 
USE tests started on So 14. Jun 17:18:22 CEST 2020

 FEATURES=' test' failed for =dev-python/pytest-5.4.2

FEATURES=' test' USE='' succeeded for =dev-python/xmlschema-1.1.3

FEATURES=' test' USE='' succeeded for =dev-python/elementpath-1.4.5

revdep tests started on So 14. Jun 18:52:44 CEST 2020

FEATURES=' test' USE='' succeeded for dev-python/pytest-mock
FEATURES=' test' USE='' succeeded for dev-python/pytest-runner
FEATURES=' test' USE='' succeeded for dev-python/pytest-timeout
 FEATURES=' test' failed for dev-python/pytest-cov
 FEATURES=' test' failed for dev-python/pytest-forked
FEATURES=' test' USE='' succeeded for dev-python/pytest-shutil
FEATURES=' test' USE='' succeeded for dev-python/pytest-expect
FEATURES=' test' USE='' succeeded for dev-python/pytest-xdist
FEATURES=' test' USE='' succeeded for dev-python/pytest-fixture-config
FEATURES=' test' USE='' succeeded for dev-python/pytest-virtualenv
Comment 14 Thomas Deutschmann gentoo-dev Security 2020-06-28 20:59:34 UTC
x86 stable
Comment 15 Sam James archtester gentoo-dev Security 2020-07-01 18:03:24 UTC
ping
Comment 16 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-07-05 14:36:57 UTC
amd64 done
Comment 17 Sergei Trofimovich (RETIRED) gentoo-dev 2020-07-08 06:46:30 UTC
Why the keywording got stuck to be fulfilled automatically: dev-python/xmlschema-1.1.3 is not keyworded on ppc/ppc64.

Keywords for dev-python/xmlschema:
      |                             |   u   |
      | a   a     p s     a   r     |   n   |
      | m   r h   p p   s l i i m m | e u s | r
      | d a m p p c a x 3 p a s 6 i | a s l | e
      | 6 r 6 p p 6 r 8 9 h 6 c 8 p | p e o | p
      | 4 m 4 a c 4 c 6 0 a 4 v k s | i d t | o
------+-----------------------------+-------+-------
1.1.3 | + + + + o o + + o ~ ~ o o o | 7 o 0 | gentoo
1.2.0 | ~ ~ ~ ~ ~ ~ ~ ~ o ~ ~ o o o | 7 #   | gentoo
1.2.1 | ~ ~ ~ ~ ~ ~ ~ ~ o ~ ~ o o o | 7 #   | gentoo
1.2.2 | ~ ~ ~ ~ ~ ~ ~ ~ o ~ ~ o o o | 7 o   | gentoo

Keywording tools don't generate needed keywords to Just keyword it:

$ nattka apply -n -a ppc 723996
# bug 723996 (STABLEREQ)
=dev-python/elementpath-1.4.5 ~ppc
=dev-python/xmlschema-1.1.3 ~ppc

This does not bring keywords in to merge packages.
Comment 18 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-07-11 07:59:17 UTC
ppc ppc64 done

all arches done