Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 723818 - dev-ruby/eventmachine fails tests
Summary: dev-ruby/eventmachine fails tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-18 21:11 UTC by Agostino Sarubbo
Modified: 2021-09-28 19:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,49.26 KB, text/plain)
2020-05-18 21:11 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-18 21:11:16 UTC
This is an auto-filed bug because dev-ruby/eventmachine fails tests.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you need further logs, feel free to ask.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-18 21:11:24 UTC
Created attachment 640206 [details]
build.log

build log and emerge --info
Comment 2 Hans de Graaff gentoo-dev 2020-05-23 06:03:07 UTC
These failures are due to OpenSSL incompatibilities and testing against obsolete protocols. This looks to be addressed upstream in various commits, so I'll wait for a new upstream release.
Comment 3 Larry the Git Cow gentoo-dev 2021-09-28 19:34:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5dd88defd7f4a8482ad22e71e72ebd7740b85fd2

commit 5dd88defd7f4a8482ad22e71e72ebd7740b85fd2
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-09-28 19:30:32 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-09-28 19:34:24 +0000

    dev-ruby/eventmachine: skip fewer tests, backport OpenSSL 1.1.1 fixes
    
    While I'd prefer to not mess with SSL patches where possible,
    on balance, it's worth using these here:
    - They're upstream patches;
    - They're being used in production by Fedora and Debian (in stable too);
    - This is the lesser evil given that tests fail with latest OpenSSL
    (hence we can't really judge if things are working) and, in the best case,
    at runtime, this will fallback to older SSL/TLS versions.
    
    Bug: https://bugs.gentoo.org/765253
    Closes: https://bugs.gentoo.org/723818
    Closes: https://bugs.gentoo.org/759250
    Fixes: f05cc0db4473e05d408574c23a494ce903173e8d
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-ruby/eventmachine/Manifest                     |  1 +
 ....2.7-r2.ebuild => eventmachine-1.2.7-r3.ebuild} | 30 +++++++++++++---------
 2 files changed, 19 insertions(+), 12 deletions(-)