Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722820 - dev-haskell/http-types does not respect CFLAGS
Summary: dev-haskell/http-types does not respect CFLAGS
Status: RESOLVED DUPLICATE of bug 722078
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Haskell Language team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags
  Show dependency tree
 
Reported: 2020-05-13 08:28 UTC by Agostino Sarubbo
Modified: 2020-05-24 17:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,22.08 KB, text/plain)
2020-05-13 08:28 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-13 08:28:02 UTC
This is an auto-filled bug because dev-haskell/http-types does not respect CFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-13 08:28:10 UTC
Created attachment 638552 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-05-24 17:48:44 UTC

*** This bug has been marked as a duplicate of bug 722078 ***