Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722548 - dev-java/icedtea-3.16.0 fails to build with sys-devel/gcc-10.1.0
Summary: dev-java/icedtea-3.16.0 fails to build with sys-devel/gcc-10.1.0
Status: RESOLVED DUPLICATE of bug 707740
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-11 20:48 UTC by crabbed halo ablution
Modified: 2020-05-11 21:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (build.log.bz2,179.11 KB, application/octet-stream)
2020-05-11 20:50 UTC, crabbed halo ablution
Details
error file referenced in build.log (hs_err_pid38836.log,72.52 KB, text/plain)
2020-05-11 20:51 UTC, crabbed halo ablution
Details
emerge --info =dev-java/icedtea-3.16.0 (emergeinfo,7.94 KB, text/plain)
2020-05-11 20:52 UTC, crabbed halo ablution
Details

Note You need to log in before you can comment on or make changes to this bug.
Description crabbed halo ablution 2020-05-11 20:48:27 UTC
icedtea-3.16.0 fails to build with gcc-10.1.0, builds fine with gcc-9.3.0

Allocated shared space: 37871616 bytes at 0x0000000800000000
Loading classes to share ...
Preload Warning: Cannot find sun/misc/PostVMInitHook
Preload Warning: Cannot find sun/usagetracker/UsageTrackerClient
Preload Warning: Cannot find sun/usagetracker/UsageTrackerClient$1
Preload Warning: Cannot find sun/usagetracker/UsageTrackerClient$4
Preload Warning: Cannot find sun/usagetracker/UsageTrackerClient$3
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f70b7f18b62, pid=38836, tid=0x00007f7017afa700
#
# JRE version: OpenJDK Runtime Environment (8.0_252-b09) (build 1.8.0_252-b09)
# Java VM: OpenJDK 64-Bit Server VM (25.252-b09 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea 3.16.0
# Distribution: Gentoo Base System release 2.7, package Gentoo icedtea-3.16.0
# Problematic frame:
# V  [libjvm.so+0x7d6b62]  Node::Node(unsigned int)+0x22
#
# Core dump written. Default location: /var/tmp/portage/dev-java/icedtea-3.16.0/work/icedtea-3.16.0/core or core.38836
#
# An error report file with more information is saved as:
# /var/tmp/portage/dev-java/icedtea-3.16.0/work/icedtea-3.16.0/hs_err_pid38836.log
[thread 140119403161344 also had an error]
[thread 140119402108672 also had an error]
[thread 140119404214016 also had an error]
[thread 140119401056000 also had an error]

[error occurred during error reporting , id 0xb]

#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   https://icedtea.classpath.org/bugzilla
#
Preload Warning: Cannot find sun/dc/DuctusRenderingEngine
Preload Warning: Cannot find sun/font/T2KFontScaler
Preload Warning: Cannot find sun/font/T2KFontScaler$1
Preload Warning: Cannot find sun/security/provider/DSA$LegacyDSA


Reproducible: Always
Comment 1 crabbed halo ablution 2020-05-11 20:50:22 UTC
Created attachment 638246 [details]
build.log.bz2
Comment 2 crabbed halo ablution 2020-05-11 20:51:16 UTC
Created attachment 638248 [details]
error file referenced in build.log
Comment 3 Sam James archtester gentoo-dev Security 2020-05-11 20:52:00 UTC

*** This bug has been marked as a duplicate of bug 707740 ***
Comment 4 crabbed halo ablution 2020-05-11 20:52:47 UTC
Created attachment 638250 [details]
emerge --info =dev-java/icedtea-3.16.0
Comment 5 crabbed halo ablution 2020-05-11 21:08:10 UTC
This is not the same bug. Icedtea-3.16.0 already has:
+src_configure() {
+	# GCC10/-fno-common handling
+	append-flags -fcommon
Comment 6 Sam James archtester gentoo-dev Security 2020-05-11 21:51:03 UTC
(In reply to crabbed halo ablution from comment #5)
> This is not the same bug. Icedtea-3.16.0 already has:
> +src_configure() {
> +	# GCC10/-fno-common handling
> +	append-flags -fcommon

That bug is not just for -fno-common errors, as explained by the maintainer in that bug. Not all of the problems have been fixed yet, as they explained.

*** This bug has been marked as a duplicate of bug 707740 ***