Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722326 - app-misc/razertool calls ar directly
Summary: app-misc/razertool calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-11 07:07 UTC by Agostino Sarubbo
Modified: 2020-09-03 10:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.08 KB, text/plain)
2020-05-11 07:07 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-11 07:07:12 UTC
This is an auto-filled bug because app-misc/razertool calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-11 07:07:20 UTC
Created attachment 637856 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-09-03 10:58:21 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7f012ff20c9f10efdba59f54a06019d026d788d5

commit 7f012ff20c9f10efdba59f54a06019d026d788d5
Author:     Bernard Cafarelli <voyageur@gentoo.org>
AuthorDate: 2020-09-03 10:57:14 +0000
Commit:     Bernard Cafarelli <voyageur@gentoo.org>
CommitDate: 2020-09-03 10:57:56 +0000

    app-misc/razertool: fix ar call, broken symlink
    
    Closes: https://bugs.gentoo.org/722326
    Closes: https://bugs.gentoo.org/726668
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>

 app-misc/razertool/files/razertool-0.0.7-ar.patch | 11 +++++++++++
 app-misc/razertool/razertool-0.0.7-r4.ebuild      | 18 ++++++++++++------
 2 files changed, 23 insertions(+), 6 deletions(-)