Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722314 - app-misc/gnuit calls ar directly
Summary: app-misc/gnuit calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-11 06:49 UTC by Agostino Sarubbo
Modified: 2021-04-19 05:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,39.63 KB, text/plain)
2020-05-11 06:49 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-11 06:49:34 UTC
This is an auto-filled bug because app-misc/gnuit calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-11 06:49:42 UTC
Created attachment 637844 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-04-19 05:03:22 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8c7e004765caf9ddac852e96bc3ba5d01e1a050a

commit 8c7e004765caf9ddac852e96bc3ba5d01e1a050a
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-04-19 04:53:48 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-04-19 05:02:51 +0000

    app-misc/gnuit: port to EAPI 7, respect AR
    
    Closes: https://bugs.gentoo.org/722314
    Signed-off-by: Sam James <sam@gentoo.org>

 .../gnuit/files/gnuit-4.9.5-format-security.patch   |  5 -----
 app-misc/gnuit/files/gnuit-4.9.5-respect-AR.patch   | 10 ++++++++++
 app-misc/gnuit/gnuit-4.9.5-r2.ebuild                | 21 ++++++++++++++++-----
 3 files changed, 26 insertions(+), 10 deletions(-)