Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722196 - app-forensics/foremost fails to compile with -fno-common or gcc-10
Summary: app-forensics/foremost fails to compile with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Auty
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-10 18:55 UTC by Agostino Sarubbo
Modified: 2020-08-28 21:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,17.65 KB, text/plain)
2020-05-10 18:55 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-10 18:55:50 UTC
This is an auto-filled bug because app-forensics/foremost fails to compile with -fno-common or gcc-10.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -fno-common" or compile it with gcc-10 that enables -fno-common by default.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-10 18:55:58 UTC
Created attachment 637712 [details]
build.log

build log and emerge --info
Comment 2 Andreas Sturmlechner gentoo-dev 2020-08-10 19:07:36 UTC
Fedora have a patch: https://src.fedoraproject.org/rpms/foremost/blob/master/f/foremost-1.5.7-gcc10.patch
Comment 3 Andreas Sturmlechner gentoo-dev 2020-08-13 21:19:18 UTC
Patch works, anyway.
Comment 4 Larry the Git Cow gentoo-dev 2020-08-28 21:02:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5f27cd2cfe23e244fc8164a2fec14dcf07c0dda6

commit 5f27cd2cfe23e244fc8164a2fec14dcf07c0dda6
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-08-28 20:55:20 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-08-28 21:02:23 +0000

    app-forensics/foremost: Fix build with GCC-10/-fno-common
    
    - EAPI-7 bump
    - Drop unused eutils.eclass
    - Drop filler word from description
    - Apply best practice to LICENSE-SLOT-KEYWORDS-IUSE
    - Break up emake block with some newlines
    - Fix PATCHES indendation
    - Add missing || die
    
    Closes: https://bugs.gentoo.org/722196
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../foremost/files/foremost-1.5.7-fno-common.patch | 99 ++++++++++++++++++++++
 app-forensics/foremost/foremost-1.5.7-r3.ebuild    | 26 +++---
 2 files changed, 115 insertions(+), 10 deletions(-)