Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722178 - app-emulation/qemu-riscv64-bin does not respect CFLAGS
Summary: app-emulation/qemu-riscv64-bin does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: RISCV project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2020-05-10 16:41 UTC by Agostino Sarubbo
Modified: 2020-05-14 05:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.70 KB, text/plain)
2020-05-10 16:41 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-10 16:41:44 UTC
This is an auto-filled bug because app-emulation/qemu-riscv64-bin does not respect CFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches".
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-10 16:41:55 UTC
Created attachment 637664 [details]
build.log

build log and emerge --info
Comment 2 Göktürk Yüksek gentoo-dev 2020-05-14 00:55:41 UTC
It's a binary package. I don't see how it can respect CFLAGS.
Comment 3 Larry the Git Cow gentoo-dev 2020-05-14 05:50:28 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b7dc7780092a6a32cc6f4d1dce9a46da5aa8a6c5

commit b7dc7780092a6a32cc6f4d1dce9a46da5aa8a6c5
Author:     Matthias Maier <tamiko@gentoo.org>
AuthorDate: 2020-05-14 05:50:09 +0000
Commit:     Matthias Maier <tamiko@gentoo.org>
CommitDate: 2020-05-14 05:50:09 +0000

    app-emulation/qemu-riscv64-bin: Silence QA warning about binary package
    
    Closes: https://bugs.gentoo.org/722178
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Matthias Maier <tamiko@gentoo.org>

 app-emulation/qemu-riscv64-bin/qemu-riscv64-bin-3.1.0-r4.ebuild | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
Comment 4 Matthias Maier gentoo-dev 2020-05-14 05:51:14 UTC
(In reply to Göktürk Yüksek from comment #2)
> It's a binary package. I don't see how it can respect CFLAGS.

We just have to tell the QA script that it indeed is a binary package (by setting QA_PREBUILT="*").