Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722040 - app-editors/hteditor-2.1.0-r1: configure: error: *** 'ar' and 'gar' missing, please install one of them or fix your $PATH ***
Summary: app-editors/hteditor-2.1.0-r1: configure: error: *** 'ar' and 'gar' missing, ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergei Trofimovich
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-10 08:32 UTC by Agostino Sarubbo
Modified: 2020-05-10 09:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,10.09 KB, text/plain)
2020-05-10 08:33 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-10 08:32:57 UTC
This is an auto-filled bug because app-editors/hteditor calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-10 08:33:04 UTC
Created attachment 637448 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-05-10 09:11:54 UTC
"""
checking for ar... no
checking for gar... no
configure: error: *** 'ar' and 'gar' missing, please install one of them or fix your $PATH ***
"""
Comment 3 Larry the Git Cow gentoo-dev 2020-05-10 09:27:18 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ccdcdc3dcf4dbcd915c3d7a462798248e46f7448

commit ccdcdc3dcf4dbcd915c3d7a462798248e46f7448
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-10 09:27:03 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-10 09:27:12 +0000

    app-editors/hteditor: use ${CHOST}-ar, not ar, gug #722040
    
    AC_PATH_PROG needs absolute path and does not add ${CHOST}
    prefix. AC_CHECK_TOOL does the opposite. Use that.
    
    Reported-by: Agostino Sarubbo
    Closes: https://bugs.gentoo.org/722040
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 app-editors/hteditor/files/hteditor-2.1.0-AR.patch | 14 ++++++++++++++
 app-editors/hteditor/hteditor-2.1.0-r1.ebuild      |  7 ++++---
 2 files changed, 18 insertions(+), 3 deletions(-)