Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721972 - sys-power/suspend-1.0_p20190605 fails with gcc:10
Summary: sys-power/suspend-1.0_p20190605 fails with gcc:10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Andrew Savchenko
URL:
Whiteboard:
Keywords:
: 743947 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-10 04:41 UTC by charles17
Modified: 2020-09-25 09:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,30.55 KB, text/x-log)
2020-05-10 04:41 UTC, charles17
Details
emerge --info (emerge --info,6.67 KB, text/plain)
2020-05-10 04:42 UTC, charles17
Details
Annex to suspend-1.0_p20190605.patch (suspend-1.0_p20200514.patch.add,3.72 KB, patch)
2020-05-14 19:10 UTC, Jiří Moravec
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description charles17 2020-05-10 04:41:28 UTC
Created attachment 637238 [details]
build log

emerge -pqv '=sys-power/suspend-1.0_p20190605::gentoo'
[ebuild   R   ] sys-power/suspend-1.0_p20190605  USE="crypt lzo -threads"
Comment 1 charles17 2020-05-10 04:42:02 UTC
Created attachment 637240 [details]
emerge --info
Comment 2 Jiří Moravec 2020-05-14 19:10:43 UTC
Created attachment 639078 [details, diff]
Annex to suspend-1.0_p20190605.patch

Chunks #1 and #2 are gcc-10 fixes
All others are just compilation warning fixes.

LOCAL_OVERLAY=...
mkdir -p "${LOCAL_OVERLAY}/sys-power/suspend"
pushd ${LOCAL_OVERLAY}/sys-power/suspend
cp -pr /usr/portage/ebuilds/sys-power/suspend/. .
mv suspend-1.0_p20190605.ebuild suspend-1.0_p20200514.ebuild

cp /usr/portage/distfiles/suspend-1.0_p20190605.patch.xz .
xz -d suspend-1.0_p20190605.patch.xz
mv suspend-1.0_p20190605.patch suspend-1.0_p20200514.patch
cat suspend-1.0_p20200514.patch.add >> suspend-1.0_p20200514.patch
xz -9 suspend-1.0_p20200514.patch
mv suspend-1.0_p20200514.patch.xz /usr/portage/distfiles/

ebuild suspend-1.0_p20200514.ebuild digest
popd
Comment 3 Sam James archtester gentoo-dev Security 2020-09-21 13:04:50 UTC
*** Bug 743947 has been marked as a duplicate of this bug. ***
Comment 4 Larry the Git Cow gentoo-dev 2020-09-25 09:42:13 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8c9b73bcb18805465de9e9888f190c25db5783a9

commit 8c9b73bcb18805465de9e9888f190c25db5783a9
Author:     Andrew Savchenko <bircoph@gentoo.org>
AuthorDate: 2020-09-25 09:34:40 +0000
Commit:     Andrew Savchenko <bircoph@gentoo.org>
CommitDate: 2020-09-25 09:41:52 +0000

    sys-power/suspend: patchlevel bump
    
    Fixes:
    - build with -fcommon / gcc-10
    - size_t format warnings
    
    Closes: https://bugs.gentoo.org/721972
    Package-Manager: Portage-3.0.8, Repoman-3.0.1
    Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>

 sys-power/suspend/Manifest                     |  1 +
 sys-power/suspend/suspend-1.0_p20200924.ebuild | 59 ++++++++++++++++++++++++++
 2 files changed, 60 insertions(+)