Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 721296 - app-arch/dump-0.4.46-r1 : /.../ld: error: main.o: multiple definition of u_spcl
Summary: app-arch/dump-0.4.46-r1 : /.../ld: error: main.o: multiple definition of u_spcl
Status: RESOLVED DUPLICATE of bug 707234
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 16:49 UTC by Toralf Förster
Modified: 2020-05-17 12:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.55 KB, text/plain)
2020-05-06 16:49 UTC, Toralf Förster
Details
app-arch:dump-0.4.46-r1:20200506-154034.log (app-arch:dump-0.4.46-r1:20200506-154034.log,33.33 KB, text/plain)
2020-05-06 16:49 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,141.33 KB, text/plain)
2020-05-06 16:49 UTC, Toralf Förster
Details
environment (environment,21.76 KB, text/plain)
2020-05-06 16:49 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.12 KB, application/x-bzip)
2020-05-06 16:49 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.36 KB, application/x-bzip)
2020-05-06 16:49 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,11.02 KB, application/x-bzip)
2020-05-06 16:49 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 16:49:33 UTC
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -falign-functions=32:25:16 -fno-common -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -o dump itime.o main.o optr.o tape.o traverse.o unctime.o  ../common/.libs/libcommon.a -lz -lbz2 -lssl -lcrypto ../compat/lib/.libs/libcompat.a -lblkid -lext2fs -lcom_err
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: main.o: multiple definition of u_spcl
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: itime.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: main.o: multiple definition of ddatev
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: itime.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 06 May 2020 02:39:02 PM UTC

emerge -qpvO app-arch/dump
[ebuild  N    ] app-arch/dump-0.4.46-r1  USE="bzip2 readline ssl zlib -debug -ermt -libressl -lzo (-selinux) -sqlite -static -test -uuid"
Comment 1 Toralf Förster gentoo-dev 2020-05-06 16:49:36 UTC
Created attachment 636524 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 16:49:39 UTC
Created attachment 636526 [details]
app-arch:dump-0.4.46-r1:20200506-154034.log
Comment 3 Toralf Förster gentoo-dev 2020-05-06 16:49:41 UTC
Created attachment 636528 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-05-06 16:49:44 UTC
Created attachment 636530 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-05-06 16:49:47 UTC
Created attachment 636532 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-06 16:49:51 UTC
Created attachment 636534 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-06 16:49:53 UTC
Created attachment 636536 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-17 12:56:41 UTC

*** This bug has been marked as a duplicate of bug 707234 ***