Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721242 - net-ftp/pure-ftpd calls ar directly
Summary: net-ftp/pure-ftpd calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL: https://github.com/jedisct1/pure-ftpd...
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-06 12:02 UTC by Agostino Sarubbo
Modified: 2020-08-16 21:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,29.19 KB, text/plain)
2020-05-06 12:02 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-06 12:02:05 UTC
This is an auto-filled bug because net-ftp/pure-ftpd calls ar directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to aarch64-unknown-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-06 12:02:14 UTC
Created attachment 636426 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-08-16 21:05:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2076c4dfe876444034d00d0677e0f3b49951d1fb

commit 2076c4dfe876444034d00d0677e0f3b49951d1fb
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2020-08-16 21:05:04 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2020-08-16 21:05:20 +0000

    net-ftp/pure-ftpd: do not call ar directly
    
    Closes: https://bugs.gentoo.org/721242
    Package-Manager: Portage-3.0.2, Repoman-2.3.23
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 .../pure-ftpd-1.0.49-do-not-call-ar-directly.patch | 23 ++++++++++++++++++++++
 net-ftp/pure-ftpd/pure-ftpd-1.0.49-r2.ebuild       |  7 +++++--
 2 files changed, 28 insertions(+), 2 deletions(-)