Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721116 - net-wireless/dump1090-3.7.2 : /.../ld: error: interactive.o: multiple definition of Modes
Summary: net-wireless/dump1090-3.7.2 : /.../ld: error: interactive.o: multiple definit...
Status: RESOLVED DUPLICATE of bug 707038
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Radio Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-05 17:16 UTC by Toralf Förster
Modified: 2020-05-21 11:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.45 KB, text/plain)
2020-05-05 17:16 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,102.49 KB, text/plain)
2020-05-05 17:16 UTC, Toralf Förster
Details
environment (environment,54.28 KB, text/plain)
2020-05-05 17:16 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.86 KB, application/x-bzip)
2020-05-05 17:16 UTC, Toralf Förster
Details
net-wireless:dump1090-3.7.2:20200505-163729.log (net-wireless:dump1090-3.7.2:20200505-163729.log,10.61 KB, text/plain)
2020-05-05 17:17 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,15.00 KB, application/x-bzip)
2020-05-05 17:17 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-05 17:16:47 UTC
x86_64-pc-linux-gnu-gcc -g -o dump1090 dump1090.o anet.o interactive.o mode_ac.o mode_s.o comm_b.o net_io.o crc.o demod_2400.o stats.o cpr.o icao_filter.o track.o util.o convert.o sdr_ifile.o sdr.o ais_charset.o sdr_rtlsdr.o -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -lpthread -lm -lrt -lrtlsdr -lusb-1.0  -lncurses -ltinfo 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: interactive.o: multiple definition of Modes
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: dump1090.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: mode_ac.o: multiple definition of Modes
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: dump1090.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue 05 May 2020 03:18:17 PM UTC

emerge -qpvO net-wireless/dump1090
[ebuild  N    ] net-wireless/dump1090-3.7.2  USE="rtlsdr -bladerf"
Comment 1 Toralf Förster gentoo-dev 2020-05-05 17:16:51 UTC
Created attachment 636256 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-05 17:16:54 UTC
Created attachment 636258 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-05 17:16:57 UTC
Created attachment 636260 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-05 17:16:59 UTC
Created attachment 636262 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-05 17:17:02 UTC
Created attachment 636264 [details]
net-wireless:dump1090-3.7.2:20200505-163729.log
Comment 6 Toralf Förster gentoo-dev 2020-05-05 17:17:05 UTC
Created attachment 636266 [details]
temp.tbz2
Comment 7 Jeroen Roovers gentoo-dev 2020-05-21 11:48:31 UTC

*** This bug has been marked as a duplicate of bug 707038 ***