Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721104 - games-emulation/gngb-20060309-r1 : /.../ld: error: emu.o: multiple definition of conf
Summary: games-emulation/gngb-20060309-r1 : /.../ld: error: emu.o: multiple definition...
Status: RESOLVED DUPLICATE of bug 707238
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-05 15:59 UTC by Toralf Förster
Modified: 2020-05-21 12:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.45 KB, text/plain)
2020-05-05 15:59 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,98.52 KB, text/plain)
2020-05-05 15:59 UTC, Toralf Förster
Details
environment (environment,58.92 KB, text/plain)
2020-05-05 15:59 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.83 KB, application/x-bzip)
2020-05-05 15:59 UTC, Toralf Förster
Details
games-emulation:gngb-20060309-r1:20200505-150207.log (games-emulation:gngb-20060309-r1:20200505-150207.log,125.31 KB, text/plain)
2020-05-05 15:59 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,6.31 KB, application/x-bzip)
2020-05-05 15:59 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,23.64 KB, application/x-bzip)
2020-05-05 15:59 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-05 15:59:14 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: emu.o: multiple definition of conf
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cpu.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: emu.o: multiple definition of key
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cpu.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue 05 May 2020 01:40:57 PM UTC

emerge -qpvO games-emulation/gngb
[ebuild  N    ] games-emulation/gngb-20060309-r1  USE="-opengl"
Comment 1 Toralf Förster gentoo-dev 2020-05-05 15:59:17 UTC
Created attachment 636226 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-05 15:59:20 UTC
Created attachment 636228 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-05 15:59:23 UTC
Created attachment 636230 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-05 15:59:27 UTC
Created attachment 636232 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-05 15:59:31 UTC
Created attachment 636234 [details]
games-emulation:gngb-20060309-r1:20200505-150207.log
Comment 6 Toralf Förster gentoo-dev 2020-05-05 15:59:34 UTC
Created attachment 636236 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-05 15:59:37 UTC
Created attachment 636238 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 12:06:58 UTC

*** This bug has been marked as a duplicate of bug 707238 ***