Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 721092 - app-misc/utimer-0.4-r1 : /.../ld: error: timer.o: multiple definition of ut_config
Summary: app-misc/utimer-0.4-r1 : /.../ld: error: timer.o: multiple definition of ut_c...
Status: RESOLVED DUPLICATE of bug 709300
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Kfir Lavi
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-05 13:57 UTC by Toralf Förster
Modified: 2020-05-21 12:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.15 KB, text/plain)
2020-05-05 13:57 UTC, Toralf Förster
Details
app-misc:utimer-0.4-r1:20200505-134027.log (app-misc:utimer-0.4-r1:20200505-134027.log,24.09 KB, text/plain)
2020-05-05 13:57 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,94.87 KB, text/plain)
2020-05-05 13:57 UTC, Toralf Förster
Details
environment (environment,14.85 KB, text/plain)
2020-05-05 13:58 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.81 KB, application/x-bzip)
2020-05-05 13:58 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,6.01 KB, application/x-bzip)
2020-05-05 13:58 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,8.39 KB, application/x-bzip)
2020-05-05 13:58 UTC, Toralf Förster
Details
files/utimer-0.4-fno-common.patch (utimer-0.4-fno-common.patch,672 bytes, patch)
2020-05-05 14:51 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-05 13:57:48 UTC
      |                                                  ^~~~~~~~~
x86_64-pc-linux-gnu-gcc  -O2 -pipe -march=native  -falign-functions=32:25:16 -fno-common  -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -o maintests maintests.o timer.o utils.o log.o -lgobject-2.0 -lglib-2.0  -lgio-2.0 -lgobject-2.0 -lglib-2.0  -lgobject-2.0 -lgthread-2.0 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: timer.o: multiple definition of ut_config
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: maintests.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: timer.o: multiple definition of savedttystate
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: maintests.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue 05 May 2020 12:38:52 PM UTC

emerge -qpvO app-misc/utimer
[ebuild  N    ] app-misc/utimer-0.4-r1  USE="nls -debug"
Comment 1 Toralf Förster gentoo-dev 2020-05-05 13:57:50 UTC
Created attachment 636208 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-05 13:57:53 UTC
Created attachment 636210 [details]
app-misc:utimer-0.4-r1:20200505-134027.log
Comment 3 Toralf Förster gentoo-dev 2020-05-05 13:57:56 UTC
Created attachment 636212 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-05-05 13:58:00 UTC
Created attachment 636214 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-05-05 13:58:02 UTC
Created attachment 636216 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-05 13:58:05 UTC
Created attachment 636218 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-05 13:58:08 UTC
Created attachment 636220 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-05 14:51:53 UTC
Created attachment 636222 [details, diff]
files/utimer-0.4-fno-common.patch
Comment 9 Jeroen Roovers gentoo-dev 2020-05-21 12:02:59 UTC

*** This bug has been marked as a duplicate of bug 709300 ***