Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721036 - net-dialup/rp-pppoe calls ar directly
Summary: net-dialup/rp-pppoe calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-05 06:30 UTC by Agostino Sarubbo
Modified: 2020-07-03 07:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,29.60 KB, text/plain)
2020-05-05 06:31 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-05 06:30:52 UTC
This is an auto-filled bug because net-dialup/rp-pppoe calls ar directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to aarch64-unknown-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-05 06:31:03 UTC
Created attachment 636112 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-07-03 07:38:47 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e25379164de96a9bb68dced4be6a1b284073e1e2

commit e25379164de96a9bb68dced4be6a1b284073e1e2
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-07-03 07:38:01 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-07-03 07:38:36 +0000

    net-dialup/rp-pppoe: Bump to version 3.14
    
    Closes: https://bugs.gentoo.org/708452
    Closes: https://bugs.gentoo.org/715950
    Closes: https://bugs.gentoo.org/721036
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 net-dialup/rp-pppoe/Manifest             |  3 +
 net-dialup/rp-pppoe/rp-pppoe-3.14.ebuild | 96 ++++++++++++++++++++++++++++++++
 2 files changed, 99 insertions(+)