Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721034 - x11-libs/libdrm calls nm directly
Summary: x11-libs/libdrm calls nm directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-05 06:30 UTC by Agostino Sarubbo
Modified: 2020-06-14 20:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.60 KB, text/plain)
2020-05-05 06:30 UTC, Agostino Sarubbo
Details
meson-log.txt (meson-log.txt,38.41 KB, text/plain)
2020-05-22 09:51 UTC, Kent Fredric (IRC: kent\n)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-05 06:30:00 UTC
This is an auto-filled bug because x11-libs/libdrm calls nm directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different NM implementation (like llvm-nm) by setting the NM variable. So this issue has been reproduced by setting the NM variable to aarch64-unknown-linux-gnu-nm and by removing the /usr/bin/nm binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-05 06:30:12 UTC
Created attachment 636110 [details]
build.log

build log and emerge --info
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2020-05-22 09:51:41 UTC
Created attachment 640876 [details]
meson-log.txt

Found CMake: /usr/bin/cmake (3.17.2)
Run-time dependency cunit found: NO (tried pkgconfig and cmake)
Program xsltproc found: YES (/usr/bin/xsltproc)
Program sed found: YES (/bin/sed)
Checking if "compiler supports __attribute__(("hidden"))" compiles: YES 
Configuring config.h using configuration
Program nm found: NO

../libdrm-2.4.100/meson.build:335:9: ERROR: Program(s) ['nm'] not found or not executable
Comment 3 Kent Fredric (IRC: kent\n) gentoo-dev 2020-06-14 20:42:54 UTC
Fixed by:

commit da03d40f146a646c38e75fd0a6fc299b5aeba505
Author: Sergei Trofimovich <slyfox@gentoo.org>
Date:   Fri Jun 12 19:34:10 2020 +0100

    meson.eclass: override 'nm' tool with tuple-prefixed one
    
    x11-libs/libdrm and media-libs/libglvnd fail to find 'nm'
    tool on sys-devel/binutils-config[-native-symlinks] system as:
    `meson.build:40:0: ERROR: Program(s) ['nm'] not found or not executable`
    
    It's caused by the code that locates the tool as:
    `prog_nm = find_program('nm')`.
    
    The change adds 'nm' tool along with other binutils tools.
    
    Closes: https://bugs.gentoo.org/720886
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>