Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721030 - net-dns/bind-tools calls ar directly
Summary: net-dns/bind-tools calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-05 06:26 UTC by Agostino Sarubbo
Modified: 2020-07-02 09:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,13.15 KB, text/plain)
2020-05-05 06:26 UTC, Agostino Sarubbo
Details
bind-tools-9.16.3-AR.patch (bind-tools-9.16.3-AR.patch,319 bytes, patch)
2020-05-26 21:36 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-05 06:26:35 UTC
This is an auto-filled bug because net-dns/bind-tools calls ar directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to aarch64-unknown-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-05 06:26:47 UTC
Created attachment 636106 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-05-26 21:36:28 UTC
Created attachment 641980 [details, diff]
bind-tools-9.16.3-AR.patch
Comment 3 Larry the Git Cow gentoo-dev 2020-07-02 09:34:37 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8964e52b9ac9bff9c7d9c1f1d3c6b5bd864cd9c8

commit 8964e52b9ac9bff9c7d9c1f1d3c6b5bd864cd9c8
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-07-02 09:34:20 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-07-02 09:34:20 +0000

    net-dns/bind-tools: Pass AR to build system
    
    Closes: https://bugs.gentoo.org/721030
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: David Seifert <soap@gentoo.org>

 net-dns/bind-tools/bind-tools-9.14.12.ebuild | 1 +
 net-dns/bind-tools/bind-tools-9.16.3.ebuild  | 1 +
 net-dns/bind-tools/bind-tools-9.16.4.ebuild  | 1 +
 3 files changed, 3 insertions(+)