Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 720972 - games-puzzle/mures-0.5-r1 : /.../ld: error: client.o: multiple definition of game_output_exit
Summary: games-puzzle/mures-0.5-r1 : /.../ld: error: client.o: multiple definition of ...
Status: RESOLVED DUPLICATE of bug 706716
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-04 17:22 UTC by Toralf Förster
Modified: 2020-05-21 12:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.79 KB, text/plain)
2020-05-04 17:22 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,52.25 KB, text/plain)
2020-05-04 17:22 UTC, Toralf Förster
Details
environment (environment,69.11 KB, text/plain)
2020-05-04 17:22 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.47 KB, application/x-bzip)
2020-05-04 17:22 UTC, Toralf Förster
Details
games-puzzle:mures-0.5-r1:20200504-171950.log (games-puzzle:mures-0.5-r1:20200504-171950.log,51.55 KB, text/plain)
2020-05-04 17:22 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.46 KB, application/x-bzip)
2020-05-04 17:22 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,21.77 KB, application/x-bzip)
2020-05-04 17:22 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-04 17:22:04 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: client.o: multiple definition of game_output_exit
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: audio_sdl.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: client.o: multiple definition of game_output_bigchange
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: audio_sdl.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Mon 04 May 2020 04:16:02 PM UTC

emerge -qpvO games-puzzle/mures
[ebuild  N    ] games-puzzle/mures-0.5-r1  USE="-opengl"
Comment 1 Toralf Förster gentoo-dev 2020-05-04 17:22:07 UTC
Created attachment 636004 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-04 17:22:10 UTC
Created attachment 636006 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-04 17:22:12 UTC
Created attachment 636008 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-04 17:22:15 UTC
Created attachment 636010 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-04 17:22:18 UTC
Created attachment 636012 [details]
games-puzzle:mures-0.5-r1:20200504-171950.log
Comment 6 Toralf Förster gentoo-dev 2020-05-04 17:22:21 UTC
Created attachment 636014 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-04 17:22:24 UTC
Created attachment 636016 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 12:07:55 UTC

*** This bug has been marked as a duplicate of bug 706716 ***