Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 720710 - dev-util/systemtap calls ar directly
Summary: dev-util/systemtap calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sven Wegener
URL: https://sourceware.org/pipermail/syst...
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-02 19:19 UTC by Agostino Sarubbo
Modified: 2020-09-08 23:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,73.15 KB, text/plain)
2020-05-02 19:19 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-02 19:19:03 UTC
This is an auto-filled bug because dev-util/systemtap calls ar directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to aarch64-unknown-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-02 19:19:43 UTC
Created attachment 635734 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-09-08 22:58:32 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8ea5dd98f52cf8e2c02c419c91438b1fb5e6578a

commit 8ea5dd98f52cf8e2c02c419c91438b1fb5e6578a
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-09-08 22:58:23 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-09-08 22:58:28 +0000

    dev-util/systemtap: respect user's AR
    
    Reported-by: Agostino Sarubbo
    Closes: https://bugs.gentoo.org/720710
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 dev-util/systemtap/files/systemtap-4.0-AR.patch | 11 +++++++++++
 dev-util/systemtap/systemtap-4.0-r1.ebuild      |  1 +
 2 files changed, 12 insertions(+)
Comment 3 Sergei Trofimovich gentoo-dev 2020-09-08 23:09:07 UTC
Proposed upstream as https://sourceware.org/pipermail/systemtap/2020q3/027024.html