Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 719954 - net-fs/davfs2-1.5.6 does not build against net-libs/neon-0.31.1
Summary: net-fs/davfs2-1.5.6 does not build against net-libs/neon-0.31.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Göktürk Yüksek
URL:
Whiteboard:
Keywords:
: 716866 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-28 19:02 UTC by kuerbiskern
Modified: 2021-01-28 19:48 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,4.65 KB, text/x-log)
2020-04-28 19:08 UTC, kuerbiskern
Details
Patch for building against neon-0.31 (neon31.patch,1.75 KB, patch)
2020-04-29 12:34 UTC, thulle
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kuerbiskern 2020-04-28 19:02:57 UTC
This is a gentoo machine on ~amd64. =net-fs/davfs2-1.5.6 does not build against net-libs/neon-0.31.1 though both are the newest version available.
From what I understand only versions lower than 0.31.0 are supported. See the build log which states: configure: incompatible neon library version 0.31.1: wanted 0.27 28 29 30


workaround: Mask >net-libs/neon-0.30.2 in /etc/portage/package.mask, emerge davfs2.

Reproducible: Always

Steps to Reproduce:
1. move ~amd64
2. 'emerge davfs2'
3. watch neon being installed in version 0.31.1 and configure of davfs2 failing
Actual Results:  
Build against not suitable neon version and configuring davfs2 failing.

Expected Results:  
Build against suitable version and davfs2 being installed.

Portage should have installed suitable versions.
Comment 1 kuerbiskern 2020-04-28 19:07:33 UTC
Portage 2.3.99 (python 3.6.10-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-9.3.0, glibc-2.31-r2, 5.4.28-gentoo x86_64)
=================================================================
System uname: Linux-5.4.28-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-gentoo-2.7
KiB Mem:    16348140 total,   7777240 free
KiB Swap:   16777212 total,  16565972 free
Timestamp of repository gentoo: Tue, 28 Apr 2020 10:00:01 +0000
Head commit of repository gentoo: b5a312d32873362067980b2a02886a4b79d08ca6
sh bash 5.0_p17
ld GNU ld (Gentoo 2.34 p1) 2.34.0
app-shells/bash:          5.0_p17::gentoo
dev-lang/perl:            5.30.2::gentoo
dev-lang/python:          2.7.18::gentoo, 3.6.10-r2::gentoo, 3.7.7-r2::gentoo, 3.8.2-r2::gentoo
dev-util/cmake:           3.17.1::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.2::gentoo
sys-devel/binutils:       2.34::gentoo
sys-devel/gcc:            9.3.0::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r2::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: 

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://ftp.fau.de/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus declarative dri dts dvd dvdr elogind emboss encode exif flac fortran gdbm gif gpm gtk iconv icu ipv6 jpeg kde kipi kwallet lcms ldap libnotify libtirpc mad mbim mng modemmanager mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt5 readline samba scanner sdl seccomp semantic-desktop spell split-usr ssl startup-notification svg tcpd tiff touchpad truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 2 kuerbiskern 2020-04-28 19:08:35 UTC
Created attachment 635094 [details]
build.log

build.log
Comment 3 thulle 2020-04-29 12:34:05 UTC
Created attachment 635160 [details, diff]
Patch for building against neon-0.31

There's a patch at https://savannah.nongnu.org/bugs/?58101 that suggests that support is already added and that it's just the build scripts that needs to be updated.
I took the patch from there and added a few things which makes it build fine here.
Comment 4 Göktürk Yüksek gentoo-dev 2020-05-06 00:54:36 UTC
*** Bug 716866 has been marked as a duplicate of this bug. ***
Comment 5 Larry the Git Cow gentoo-dev 2020-05-06 01:27:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9ec35711f04f10bad8962d8e17590b412a73a267

commit 9ec35711f04f10bad8962d8e17590b412a73a267
Author:     Göktürk Yüksek <gokturk@gentoo.org>
AuthorDate: 2020-05-06 01:11:19 +0000
Commit:     Göktürk Yüksek <gokturk@gentoo.org>
CommitDate: 2020-05-06 01:26:36 +0000

    net-fs/davfs2: add support for neon-0.31 #719954
    
    Thanks thulle for the patch!
    
    Closes: https://bugs.gentoo.org/719954
    Package-Manager: Portage-2.3.69, Repoman-2.3.14
    Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>

 net-fs/davfs2/davfs2-1.5.6.ebuild                  |  3 +-
 .../davfs2/files/davfs2-1.5.6-neon31-support.patch | 45 ++++++++++++++++++++++
 2 files changed, 47 insertions(+), 1 deletion(-)