Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 71897 - gthumb 2.6.0.1 missing XML-Parser dependency?
Summary: gthumb 2.6.0.1 missing XML-Parser dependency?
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-20 15:52 UTC by David Bélanger
Modified: 2014-04-09 06:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Bélanger 2004-11-20 15:52:49 UTC
Hi,

gthumb-2.6.0.1 failed to compile with:

----------------------

Calculating world dependencies ...done!
[ebuild     U ] media-gfx/gthumb-2.6.0.1 [2.4.2] -debug -gphoto2 +jpeg +png -tiff 0 kB 

Total size of downloads: 0 kB

Do you want me to merge these packages? [Yes/No] 

(output skipped)

checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for xgettext... /usr/bin/xgettext
checking for catalogs to be installed...  am az be ca cs da de en_CA en_GB es eu fi fr ga gu hr hu id it ja ko lt lv mk ml ms nb nl no pa pl pt pt_BR ru sk sq sr sr@Latn sv uk zh_CN zh_TW
checking for intltool >= 0.21... 0.31.3 found
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! ERROR: media-gfx/gthumb-2.6.0.1 failed.
!!! Function econf, Line 449, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

-----------

Emerging dev-perl/XML-Parser manually got past the problem (currently compiling on my slow machine)

Missing dep in either gthumb or one of the packages in its dependency tree?

Thanks,
David

My emerge info:
Portage 2.0.51-r2 (default-ppc-2004.3, gcc-3.4.3, glibc-2.3.4.20041102-r0, 2.6.9-gentoo-r2 ppc)
=================================================================
System uname: 2.6.9-gentoo-r2 ppc 750FX
Gentoo Base System version 1.6.6
distcc 2.18.2 powerpc-unknown-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.9.2
Binutils: sys-devel/binutils-2.15.90.0.3-r3
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=750 -pipe"
CHOST="powerpc-unknown-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -mcpu=750 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs buildpkg ccache distcc distlocks"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X berkdb dvd emacs esd gdbm gif gnome-libs gtk gtk2 imlib jpeg libwww motif nls no_wxgtk1 oggvorbis opengl oss pam perl png ppc python readline ruby sdl ssl tcltk tcpd tetex truetype userlocales"
Comment 1 David Bélanger 2004-11-20 20:07:24 UTC
Hi,

XML-Parser is a dep of intltool.

So the problem seemed to be specific to my system and temporary.

I have no clue what went wrong the first time.  I just unmerged XML-Parser and now emerge world correctly asked to get it installed.


David
Comment 2 David Bélanger 2004-11-20 20:12:30 UTC
Closing as INVALID for reason explained above.
Comment 3 Samuli Suominen gentoo-dev 2014-04-09 06:58:53 UTC

*** This bug has been marked as a duplicate of bug 41124 ***