Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718592 - app-text/scdoc calls cc directly
Summary: app-text/scdoc calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Aisha Tammy
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-04-20 10:16 UTC by Agostino Sarubbo
Modified: 2020-10-28 00:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.36 KB, text/plain)
2020-04-20 10:16 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-20 10:16:00 UTC
This is an auto-filled bug because app-text/scdoc calls cc directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to temporarily move the /usr/bin/cc - /usr/bin/gcc binaries.
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-20 10:16:09 UTC
Created attachment 633830 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-10-25 18:42:56 UTC
For my system the following patch seems to be enough:

--- a/app-text/scdoc/scdoc-1.11.0.ebuild
+++ b/app-text/scdoc/scdoc-1.11.0.ebuild
@@ -35,7 +35,7 @@ src_compile() {
                        CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
                mv scdoc hostscdoc || die 'Failed to rename host scdoc'
        fi
-       emake LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
+       emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
 }

 src_install() {
Comment 3 Aisha Tammy 2020-10-25 20:31:50 UTC
thanks slyfox
I made the PR with the change
Comment 4 Larry the Git Cow gentoo-dev 2020-10-28 00:04:04 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=13fc300f9769f245a1ff935f487ae79a7b4000c2

commit 13fc300f9769f245a1ff935f487ae79a7b4000c2
Author:     Aisha Tammy <gentoo@aisha.cc>
AuthorDate: 2020-10-25 19:07:40 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-10-27 23:54:44 +0000

    app-text/scdoc: fix CC calls
    
    Closes: https://bugs.gentoo.org/718592
    
    Package-Manager: Portage-3.0.8, Repoman-3.0.1
    Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
    Closes: https://github.com/gentoo/gentoo/pull/18032
    Signed-off-by: Sam James <sam@gentoo.org>

 app-text/scdoc/scdoc-1.10.0.ebuild   | 2 +-
 app-text/scdoc/scdoc-1.10.1.ebuild   | 2 +-
 app-text/scdoc/scdoc-1.11.0.ebuild   | 2 +-
 app-text/scdoc/scdoc-1.9.3-r1.ebuild | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)