Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718072 - app-arch/unrar calls ar directly
Summary: app-arch/unrar calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Thomas Deutschmann
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-04-18 16:41 UTC by Agostino Sarubbo
Modified: 2020-04-18 18:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,14.74 KB, text/plain)
2020-04-18 16:41 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-18 16:41:26 UTC
This is an auto-filled bug because app-arch/unrar calls ar directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to temporarily move the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-18 16:41:35 UTC
Created attachment 633616 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-04-18 18:55:01 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1de6205d4c814f163590562c2066998b9ce488cd

commit 1de6205d4c814f163590562c2066998b9ce488cd
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2020-04-18 18:54:53 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2020-04-18 18:54:53 +0000

    app-arch/unrar: don't call AR directly
    
    Closes: https://bugs.gentoo.org/718072
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 app-arch/unrar/unrar-5.9.2.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)