Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718032 - media-libs/mesa calls nm directly ( meson.build:1731:2: ERROR: Program(s) ['nm'] not found or not executable )
Summary: media-libs/mesa calls nm directly ( meson.build:1731:2: ERROR: Program(s) ['n...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-04-18 10:23 UTC by Agostino Sarubbo
Modified: 2020-06-14 22:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,192.21 KB, text/plain)
2020-04-18 10:23 UTC, Agostino Sarubbo
Details
meson-log.txt (meson-log.txt,149.54 KB, text/plain)
2020-05-27 10:35 UTC, Kent Fredric (IRC: kent\n)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-18 10:23:26 UTC
This is an auto-filled bug because media-libs/mesa calls nm directly.
The issue was originally discovered on x86, but it may be reproducible on other arches as well.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to temporarily move the /usr/bin/nm binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-18 10:23:33 UTC
Created attachment 633568 [details]
build.log

build log and emerge --info
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2020-05-27 10:35:07 UTC
Created attachment 642006 [details]
meson-log.txt

Failure context:

Run-time dependency glproto found: YES 1.4.17
Run-time dependency dri2proto found: YES 2.8
Run-time dependency xxf86vm found: YES 1.1.4
Run-time dependency xcb-xfixes found: YES 1.14
Run-time dependency xcb-randr found: YES 1.14
Run-time dependency xrandr found: YES 1.5.2
Program nm found: NO

../mesa-20.1.0-rc4/meson.build:1731:2: ERROR: Program(s) ['nm'] not found or not executable

A full log can be found at /var/tmp/portage/media-libs/mesa-20.1.0_rc4/work/mesa-20.1.0-rc4-abi_x86_32.x86/meson-logs/meson-log.txt