Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 717672 - dev-libs/boost-1.72.0-r1: failed (compile phase)
Summary: dev-libs/boost-1.72.0-r1: failed (compile phase)
Status: RESOLVED DUPLICATE of bug 717594
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: David Seifert
Depends on:
Reported: 2020-04-16 09:30 UTC by Hugo Ribeiro
Modified: 2020-04-17 09:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

boost-1.72.0-r1_-_build.log (build.log,228.77 KB, application/octet-stream)
2020-04-16 09:30 UTC, Hugo Ribeiro
emerge --info =dev-libs/boost-1.72.0-r1::gentoo (boost-1.72.0-r1_-_emerge--info,7.57 KB, text/plain)
2020-04-16 09:33 UTC, Hugo Ribeiro

Note You need to log in before you can comment on or make changes to this bug.
Description Hugo Ribeiro 2020-04-16 09:30:38 UTC
Created attachment 633168 [details]

It seems I am unable to re-emerge boost-1.72.0-r1. The rebuild was needed after passing the "--changed-deps=y" option to emerge. I am not an expert, but looking at the log output, it seems this might be the problem: 

"/usr/lib/python3.7/site-packages/numpy/core/include/numpy/numpyconfig.h:4:10: fatal error: _numpyconfig.h: No such file or directory
    4 | #include "_numpyconfig.h""

I tried rebuilding python-3.7.7-r1 and numpy-1.17.4-r2 (both "emerge" fine) but still no luck with boost.
Comment 1 Hugo Ribeiro 2020-04-16 09:33:44 UTC
Created attachment 633170 [details]
emerge --info =dev-libs/boost-1.72.0-r1::gentoo
Comment 2 Hugo Ribeiro 2020-04-16 20:42:16 UTC
This is probably related to the two following bugs:


and has nothing to do with boost.
Comment 3 David Seifert gentoo-dev 2020-04-17 09:44:51 UTC

*** This bug has been marked as a duplicate of bug 717594 ***