Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 717360 - sys-kernel/gentoo-sources-5.4.28: flickering black lines on Mobility Radeon 7500
Summary: sys-kernel/gentoo-sources-5.4.28: flickering black lines on Mobility Radeon 7500
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-13 20:25 UTC by lebkoungcity
Modified: 2020-08-09 18:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Photo of flickering black lines on screen. (IMG-20200404-001931 (1).jpg,318.30 KB, image/jpeg)
2020-04-13 20:25 UTC, lebkoungcity
Details
Xorg.0.log (Xorg.0.log,30.23 KB, text/x-log)
2020-04-13 20:26 UTC, lebkoungcity
Details
dmesg (dmesg,46.97 KB, text/plain)
2020-04-13 20:27 UTC, lebkoungcity
Details
config-5.4.28-gentoo (config-5.4.28-gentoo,118.22 KB, text/plain)
2020-04-13 20:29 UTC, lebkoungcity
Details
emerge --info (file_717360.txt,6.51 KB, text/plain)
2020-04-16 20:30 UTC, lebkoungcity
Details
bisect.log (bisect.log,4.16 KB, text/x-log)
2020-05-23 08:10 UTC, lebkoungcity
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lebkoungcity 2020-04-13 20:25:43 UTC
Created attachment 632732 [details]
Photo of flickering black lines on screen.

I have flickering black lines on X when booting the kernel I compiled from sys-kernel/gentoo-sources-5.4.28. No problems with sys-kernel/gentoo-sources-4.19.97.
I re-compiled the kernel three times, the last one after 'make clean', 'make mrproper and 'make distclean' and re-creating .config from the working '4.19.97' with 'make oldconfig'.

Hardware:
ThinkPad R40 with RV200/M7 [Mobility Radeon 7500]

in make.conf: VIDEO_CARDS="radeon r100"

Attachments are:
- picture of screen with flickering fine black lines
- Xorg.0.log
- dmesg
- config (5.4.28-gentoo)
- emerge --info
Comment 1 lebkoungcity 2020-04-13 20:26:33 UTC
Created attachment 632734 [details]
Xorg.0.log
Comment 2 lebkoungcity 2020-04-13 20:27:45 UTC
Created attachment 632736 [details]
dmesg
Comment 3 lebkoungcity 2020-04-13 20:29:01 UTC
Created attachment 632738 [details]
config-5.4.28-gentoo
Comment 4 lebkoungcity 2020-04-13 20:30:33 UTC
see also:
https://forums.gentoo.org/viewtopic-t-1110960.html

Thanks for your attention!
Comment 5 Jonas Stein gentoo-dev 2020-04-14 01:31:58 UTC
Why do you think this is a gentoo related bug?
Comment 6 lebkoungcity 2020-04-16 20:30:29 UTC
Created attachment 633274 [details]
emerge --info

Forgot to add emerge --info, now added.
Comment 7 lebkoungcity 2020-04-16 20:42:11 UTC
(In reply to Jonas Stein from comment #5)
> Why do you think this is a gentoo related bug?

I searched the net for problems like this but found only topics that are either several years old and/or have other impacts.
Maybe I just didn't find related postings? Then I'd be sorry for opening this bug...


In the meantime I have also tried sys-kernel/gentoo-sources-5.6.3 and the result is the same - flickering black lines.
Comment 8 Mike Pagano gentoo-dev 2020-05-21 17:08:51 UTC
Standard steps here:


Try the latest vanilla-sources 5.6.X kernel and see if it's there.
You can also try the latest vanilla-sources 5.4.X kernel (latest)

If the problem still exists, find the last working kernel and first non-working kernel and attempt a git bisect.

It's a little tedious, but it does sometimes identify an offending commit.

https://git-scm.com/docs/git-bisect
Comment 9 lebkoungcity 2020-05-23 08:08:21 UTC
Thanks a lot for your suggestion.
By coincidence I did start that last weekend and now I have the results. (I followed these instructions: https://wiki.gentoo.org/wiki/Kernel_git-bisect )
I add the log as attachment and it seems this is the commit in question:

commit 33b3ad3788aba846fc8b9a065fe2685a0b64f713
Author: Christoph Hellwig <hch@lst.de>
Date:   Thu Aug 15 09:27:00 2019 +0200

    drm/radeon: handle PCIe root ports with addressing limitations
    
    radeon uses a need_dma32 flag to indicate to the drm core that some
    allocations need to be done using GFP_DMA32, but it only checks the
    device addressing capabilities to make that decision.  Unfortunately
    PCIe root ports that have limited addressing exist as well.  Use the
    dma_addressing_limited instead to also take those into account.
    
    Reviewed-by: Christian König <christian.koenig@amd.com>
    Reported-by: Atish Patra <Atish.Patra@wdc.com>
    Signed-off-by: Christoph Hellwig <hch@lst.de>
    Signed-off-by: Alex Deucher <alexander.deucher@amd.com>

 drivers/gpu/drm/radeon/radeon.h        |  1 -
 drivers/gpu/drm/radeon/radeon_device.c | 12 +++++-------
 drivers/gpu/drm/radeon/radeon_ttm.c    |  2 +-
 3 files changed, 6 insertions(+), 9 deletions(-)
Comment 10 lebkoungcity 2020-05-23 08:10:11 UTC
Created attachment 640964 [details]
bisect.log
Comment 11 lebkoungcity 2020-06-11 09:17:16 UTC
Now that there is the result of the bisect - What to do next? Where should I take it/report it?

Thanks a lot! :)
Comment 12 Saayuj Santhoshkumar 2020-06-11 13:34:25 UTC
(In reply to lebkoungcity from comment #11)
> Now that there is the result of the bisect - What to do next? Where should I
> take it/report it?
> 
> Thanks a lot! :)

This might be the best place --> https://bugzilla.kernel.org/
Comment 13 lebkoungcity 2020-08-09 18:05:04 UTC
I reported it here: https://bugzilla.kernel.org/show_bug.cgi?id=208263 weeks ago but there was never any reaction to this. (And today I updated it, see below.) Is there any other place to put it?



Anyway, today I tried sys-kernel/gentoo-sources-5.8.0-r1 and the flickering is still there.

When I disable 'High Memory Support' the flickering does not happen. (I found that somewhere on the net.) But with 'High Memory Support' set to '4GB' it shows up. Unfortunately I need all of the installed 2GB RAM so I need to set 'High Memory Support' to '4GB'...