Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 71709 - xorg-x11-6.8.0-r3 gives Gnome "Error activating XKB configuration."
Summary: xorg-x11-6.8.0-r3 gives Gnome "Error activating XKB configuration."
Status: RESOLVED DUPLICATE of bug 47243
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2004-11-18 15:46 UTC by Jonathan Hudson
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Hudson 2004-11-18 15:46:44 UTC
After emerging xorg-x11-6.8.0-r3, logging into Gnome gives

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
Gentoo Linux (The X.Org Foundation 6.8.0, revision r3-

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
jrh $ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc101", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc101", "us", "", ""
jrh $ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc101
 overrideSettings = false
 options = [compose     compose:ralt]
 update_handlers = []

This did not happen with earlier Xorg ebuilds.

Reproducible: Always
Steps to Reproduce:
Comment 1 Gustavo Ribeiro Alves 2004-11-19 21:46:07 UTC
same problem here, but with xorg 6.7.0-r3.

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc104", "us_intl", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc104", "us_intl", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb layouts = [us_intl]
 model = pc104
 overrideSettings = false
 options = []
 update_handlers = []
Comment 2 Jonathan Hudson 2004-11-24 12:35:30 UTC
Solved it! After a lot of messing around with -kb and other options, emerging and backing out Xorg versions etc, I noticed that the xkbcomp file in /usr/X11R6/lib/X11/xkb was 0 bytes. Replacing this with the binary from /usr/X11R6/bin solved the problem. 

I assume that the xorg-x11-6.8.0-r3 install left the 0 byte file there. 

It now "worksforme".
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2004-11-24 14:25:02 UTC
This is a duplicate.
Comment 4 Donnie Berkholz (RETIRED) gentoo-dev 2004-11-24 14:25:08 UTC

*** This bug has been marked as a duplicate of 47243 ***