Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 716960 - sci-libs/suitesparse-5.4.0 stabilisation
Summary: sci-libs/suitesparse-5.4.0 stabilisation
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Orlitzky
URL:
Whiteboard:
Keywords: PullRequest, STABLEREQ
Depends on: 713582 729634 729636
Blocks: EAPI5Removal
  Show dependency tree
 
Reported: 2020-04-10 16:52 UTC by Andreas Sturmlechner
Modified: 2021-03-21 20:15 UTC (History)
4 users (show)

See Also:
Package list:
sci-libs/suitesparse-5.4.0 sci-libs/suitesparseconfig-5.4.0 sci-libs/amd-2.4.6 sci-libs/btf-1.2.6 sci-libs/camd-2.4.6 sci-libs/ccolamd-2.9.6 sci-libs/cholmod-3.0.13 sci-libs/colamd-2.9.6 sci-libs/cxsparse-3.2.0 sci-libs/klu-1.3.9 sci-libs/ldl-2.2.6 sci-libs/spqr-2.0.9 sci-libs/umfpack-5.7.9 sci-libs/metis-5.1.0-r4 dev-cpp/tbb-2019.8 sparc
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2020-04-10 16:52:27 UTC
How about that?
Comment 1 Michael Orlitzky gentoo-dev 2020-04-10 17:13:28 UTC
We should stabilize all of suitesparse at once, most likely, but first I want the fix from his PR =)
Comment 2 Andreas Sturmlechner gentoo-dev 2020-04-10 17:14:27 UTC
That already happened, picked in commit 0b6f695a.
Comment 3 Bernd 2020-04-10 18:13:18 UTC
I'm happy with this, but we have to remove the old 5.6.2 then ASAP after stablizing this one, to get rid of the CI issue.
Comment 4 Michael Orlitzky gentoo-dev 2020-04-10 20:00:39 UTC
Targets: amd64, arm64, ppc, ppc64, x86, and sparc (who all have sci-libs/suitesparseconfig-4.2.1-r1 stable).

Before we can do that, we need a few things keyworded:

sci-libs/suitesparse: arm64, ppc, ppc64, sparc
sci-libs/btf: arm64
sci-libs/cxsparse: arm64
sci-libs/klu: arm64, ppc, ppc64, sparc
sci-libs/ldl: arm64
sci-libs/spqr: arm64, sparc

I'll open a blocker for those.
Comment 5 Andreas Sturmlechner gentoo-dev 2020-06-18 13:33:16 UTC
Is there any good reason to wait any longer here?
Comment 6 Michael Orlitzky gentoo-dev 2020-06-18 13:50:31 UTC
(In reply to Andreas Sturmlechner from comment #5)
> Is there any good reason to wait any longer here?

Many of these packages don't even have keywords on the arches that need to be stabilized, so we're waiting on bug 716982...
Comment 7 Andreas Sturmlechner gentoo-dev 2020-06-18 13:52:01 UTC
(In reply to Michael Orlitzky from comment #6)
> (In reply to Andreas Sturmlechner from comment #5)
> > Is there any good reason to wait any longer here?
> 
> Many of these packages don't even have keywords on the arches that need to
> be stabilized, so we're waiting on bug 716982...
You don't have to wait for the very last (~hppa) arch to finish keywording for starting stabilisation here.
Comment 8 Andreas Sturmlechner gentoo-dev 2020-06-18 13:59:23 UTC
You may even go as far as drop sci-libs/umfpack to ~hppa later, seeing how there is no stable revdep.
Comment 9 Michael Orlitzky gentoo-dev 2020-06-18 14:25:25 UTC
(In reply to Andreas Sturmlechner from comment #8)
> You may even go as far as drop sci-libs/umfpack to ~hppa later, seeing how
> there is no stable revdep.

That sounds OK. I'm on a tiny laptop at the moment about to "walk into" a seminar, so if you want to kick this off, feel free.
Comment 10 Andreas Sturmlechner gentoo-dev 2020-06-18 15:05:17 UTC
Okay then, arches please stabilise.
Comment 11 NATTkA bot gentoo-dev 2020-06-18 15:09:06 UTC
Sanity check failed:

> sci-libs/cholmod-3.0.13
>   depend ppc stable profile default/linux/powerpc/ppc32/17.0 (27 total)
>     >=sci-libs/metis-5.1.0
>     sci-libs/parmetis
>   rdepend ppc stable profile default/linux/powerpc/ppc32/17.0 (27 total)
>     >=sci-libs/metis-5.1.0
>     sci-libs/parmetis
>   depend ppc64 dev profile default/linux/ppc64le/17.0/desktop/plasma (2 total)
>     >=sci-libs/metis-5.1.0
>     sci-libs/parmetis
>   rdepend ppc64 dev profile default/linux/ppc64le/17.0/desktop/plasma (2 total)
>     >=sci-libs/metis-5.1.0
>     sci-libs/parmetis
> sci-libs/spqr-2.0.9
>   depend amd64 stable profile default/linux/amd64/17.0 (67 total)
>     >=sci-libs/metis-5.1.0
>   depend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (4 total)
>     >=sci-libs/metis-5.1.0
>   rdepend amd64 stable profile default/linux/amd64/17.0 (67 total)
>     >=sci-libs/metis-5.1.0
>   rdepend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (4 total)
>     >=sci-libs/metis-5.1.0
>   depend sparc stable profile default/linux/sparc/17.0 (8 total)
>     >=sci-libs/metis-5.1.0
>     dev-cpp/tbb
>   rdepend sparc stable profile default/linux/sparc/17.0 (8 total)
>     >=sci-libs/metis-5.1.0
>     dev-cpp/tbb
Comment 12 NATTkA bot gentoo-dev 2020-06-18 15:12:44 UTC
Unable to check for sanity:

> no match for package: sci-libs/metis-5.1.0
Comment 13 Agostino Sarubbo gentoo-dev 2020-06-21 17:05:39 UTC
ppc stable
Comment 14 Agostino Sarubbo gentoo-dev 2020-06-21 17:10:38 UTC
ppc64 stable
Comment 15 Agostino Sarubbo gentoo-dev 2020-06-22 06:59:48 UTC
amd64 stable
Comment 16 Sam James archtester gentoo-dev Security 2020-06-22 19:08:57 UTC
arm64 stable
Comment 17 Rolf Eike Beer archtester 2020-06-25 18:46:16 UTC
Half of the packages fail build with USE=doc because of sandbox violations of TeX things. I was told it's basically the VARTEXFONTS workaround in the ebuilds.
Comment 18 Sam James archtester gentoo-dev Security 2020-07-19 16:04:35 UTC
x86 stable
Comment 19 Andreas Sturmlechner gentoo-dev 2020-07-19 18:21:40 UTC
Pending Cleanup-CI-Run.