Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 716596 - x11-misc/wdm stops registering session
Summary: x11-misc/wdm stops registering session
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Reported: 2020-04-07 18:29 UTC by Klaus Ethgen
Modified: 2022-06-17 11:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Xorg.0.log (file_716596.txt,18.02 KB, text/plain)
2022-06-17 06:03 UTC, Klaus Ethgen

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Ethgen 2020-04-07 18:29:23 UTC
Recently, wdm stopped registering sessions. That is especially bad as it prevent my display to lock when I send the laptop to sleep leaving me with a unlocked session.

The reason is that pinky cannot see the session as it is not registered anymore to /run/utmp

I tried to find the real reason as wdm was updated last at 2019-10-17 so that update did not trigger the bug.

But there are several relevant tools updated back to February that could be the reason. Unfortunately the old versions are not in gentoo anymore so I am unnable to test.

Packages that was updated or rebuild in that time range are:
- x11-apps/xinit (rebuild as 1.4.1 was installed in july last year)
- x11-apps/sessreg (Also rebuild and version 1.1.2 from july last year)
- sys-libs/pam (Update from 1.3.1-r1 to 1.3.1-r2 although the update in january from 1.3.0-r2 could also have triggered that bug)

Reproducible: Always

Steps to Reproduce:
1. login with wdm

Actual Results:  
~> pinky    
Login    Name                 TTY      Untätig Wann             Wo   

Expected Results:  
~> pinky    
Login    Name                 TTY      Untätig Wann             Wo   
xxxx     Xxx Xxx             *console  xxx     2020-xx-xx xx:xx :0
Comment 1 Klaus Ethgen 2020-04-07 18:38:13 UTC
Some workaround:

When I add the following line to /etc/X11/wdm/GiveConsole, it works again:

exec sessreg -a -l "$DISPLAY" -u /run/utmp -x /etc/X11/wdm/Xservers "$USER"
Comment 2 Jonas Stein gentoo-dev 2021-02-21 02:25:00 UTC
Which version of wdm did you try?

It is sad to read that you have problems with wdm. The situation seems to be a bit more complicate and requires some analysis.
We can not help you efficiently via bug tracker. 

I have had very good experience on the gentoo IRC [1] with questions like this. Of course there are also forums and mailing lists [2,3,4].

Comment 3 Klaus Ethgen 2021-02-21 09:10:04 UTC
curently x11-misc/wdm-1.28-r6 and I checked, the bug is still valid.

Tell me what you need.

Regarding other channels, I had bad experiences with freenode as it requires logging in but I have no account there. It is usually not easy to get to a channel to talk together.

About the other channels, that need to register everytime with a new account just to fix that single bug is not very user friendly. (Even bugzilla needs an separate account. But that I created as there are some bugs that needsx to report.) I like bug trackers that does not need to register like the one of devuan or debian.

However, feel free to contact me direct by e-mail. I also have a jabber live...
Comment 4 Klaus Ethgen 2022-06-17 06:02:39 UTC
I do not know if it is related. But after updating two dependent libraries today:
- media-libs/mesa-22.0.5 [22.0.3]
- x11-libs/libxkbcommon-1.4.1 [1.4.0]

… it fail to start completly:
Cannot read randomFile "/dev/mem", errno = 1

X.Org X Server
X Protocol Version 11, Revision 0
Current Operating System: Linux chua 5.16.17-gentoo-x86_64 #1 SMP PREEMPT Sun Mar 27 14:59:04 CET 2022 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.16.17-gentoo-x86_64 root=/dev/mapper/sysvg-lv_root ro enforcing=0 selinux=0 net.ifnames=0 dolvm dobtrfs noresume
Current version of pixman: 0.40.0
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 17 07:58:55 2022
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
syntax error: line 1 of evdev
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Error interpreting include file "evdev"
>                   Exiting
>                   Abandoning keycodes file "default"
Errors from xkbcomp are not fatal to the X server
syntax error: line 1 of evdev
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Error interpreting include file "evdev"
>                   Exiting
>                   Abandoning keycodes file "default"
Errors from xkbcomp are not fatal to the X server
XKB: Failed to compile keymap
Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.
Fatal server error:
(EE) Failed to activate virtual core keyboard: 2(EE) 
Please consult the The X.Org Foundation support 
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(II) AIGLX: Suspending AIGLX clients for VT switch
(EE) Server terminated with error (1). Closing log file.
server unexpectedly died
Server for display :0 can't be started, session disabled

(I will attach the xorg log)
Comment 5 Klaus Ethgen 2022-06-17 06:03:56 UTC
Created attachment 785834 [details]
Comment 6 Klaus Ethgen 2022-06-17 06:08:22 UTC
My Keyboard configuration is:
Section "InputClass"
   Identifier "keyboard-all"
   Driver "evdev"
   Option "XkbLayout" "de"
   Option "XkbVariant" "nodeadkeys"
   Option "XkbOptions" "lv3:ralt_switch_multikey,terminate:ctrl_alt_bksp,shift:breaks_caps"
   MatchIsKeyboard "on"
Comment 7 Klaus Ethgen 2022-06-17 11:56:22 UTC
Ignore my last comment about kbd. It was thought for another bug and is solved by reinstalling x11-misc/xkeyboard-config.