Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 71629 - gcc-3.3.5-r1 TODO
Summary: gcc-3.3.5-r1 TODO
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: SpanKY
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-17 18:25 UTC by SpanKY
Modified: 2005-01-14 14:26 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SpanKY gentoo-dev 2004-11-17 18:25:11 UTC
- update manpages
- port pie patches
- see if PIE is what causes GCC to barf on ia64
- port changes from 3.4.3 back to 3.3.5-r1
Comment 1 Stephane Loeuillet 2004-11-18 08:36:19 UTC
would there be a libstdc++-v3-3.3.5 ?
Comment 2 George Nussbaum 2004-11-18 18:24:21 UTC
Failing here:

checking whether the C compiler ( /var/tmp/portage/gcc-3.3.5/work/build/gcc/xgcc -B/var/tmp/portage/gcc-3.3.5/work/build/gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -B/usr/x86_64-pc-linux-gnu/lib/ -isystem /usr/x86_64-pc-linux-gnu/include -O2 -O2 -march=athlon64 -pipe ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
make: *** [configure-target-libiberty] Error 1


make.conf:

# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=athlon64 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.binarycompass.org http://ftp-mirror.internap.com/pub/gentoo/"
USE="-gtk -gnome qt kde dvd alsa cdr"
ACCEPT_KEYWORDS="amd64 ~amd64"
ALSA_CARDS="via82xx"
PORTDIR_OVERLAY="/usr/local/portage"
Comment 3 solar (RETIRED) gentoo-dev 2004-11-20 09:28:36 UTC
Peter, 
Please attach any proposed patches for gcc-3.3.5 which solve comment #0
Comment 4 Travis Tilley (RETIRED) gentoo-dev 2004-11-20 16:34:16 UTC
well the last part is pretty much done. i've fixed the multilib stuff and added bounds checking support...

i'm not going to touch the pie patch stuff if psm has already done this. where might i find those?
Comment 5 Travis Tilley (RETIRED) gentoo-dev 2004-11-21 08:32:28 UTC
the manpages have been updated, and psm released new pie patches.
Comment 6 Travis Tilley (RETIRED) gentoo-dev 2004-11-21 09:04:51 UTC
...and now SLOT funkiness has also been dealt with. so, when you get back, the only item left on your todo list is to re-test the ebuild on ia64 with all of these changes made.
Comment 7 SpanKY gentoo-dev 2004-11-21 21:40:06 UTC
ok, the TODO is covered

i have other issues outside the scope of this that'll i'll take up on irc
Comment 8 Goyo Roth 2004-11-29 16:54:24 UTC
RE: comment #2

I have found this same problem when using the -march flag in my CFLAGS on AMD64. As yet, I have found no acceptable solution. Digging deeper revealed that the march flag was definitely to blame. I've tried a few variations to no avail. I have eliminated the flag entirely, but the resulting compiler cannot accept this architecture flag either. 

Could somebody please fix this, suggest a workaround, or disable it for AMD64?
Comment 9 Jamie Kramer 2005-01-14 11:42:13 UTC
This is still failing. I'm including my post from forum http://forums.gentoo.org/viewtopic.php?t=27486&postdays=0&postorder=asc&start=25 Hope its not too long.

I am getting the "configure: error: installation or configuration problem: C compiler cannot create executables" error too when trying to update gcc.

* sys-devel/gcc
Latest version available: 3.3.5-r1
Latest version installed: 3.3.4-r1

emerge -pvuD gcc
These are the packages that I would merge, in order:
Calculating dependencies ...done!
[ebuild U ] sys-devel/gcc-3.3.5-r1 [3.3.4-r1] -bootstrap -boundschecking -build -debug (-emul-linux-x86) +fortran -gcj +gtk -hardened (-ip28) -multilib -multislot (-n32) (-n64) +nls -nocxx -objc -static (-uclibc) 0 kB

I eventually get this error when actually trying to update:

checking for ANSI C header files... no
checking for uintptr_t... no
checking for pid_t... yes
checking whether the C compiler ( /var/tmp/portage/gcc-3.3.5-r1/work/build/gcc/xgcc -B/var/tmp/portage/gcc-3.3.5-r1/work/build/gcc/ -B/usr/i686-pc-linux-gnu/bin/ -B/usr/i686-pc-linux-gnu/lib/ -isystem /usr/i686-pc-linux-gnu/include -O2 -march=k8 -pipe -O2 ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
make: *** [configure-target-libiberty] Error 1

!!! ERROR: sys-devel/gcc-3.3.5-r1 failed.
!!! Function gcc_do_make, Line 1047, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


I too tried all these steps (except 5):
Quote:

1) Check make.conf for errors / weirdness
2) sh make.conf
3) "gcc-config -l " and if necessary change with "gcc-config N"
4) fix_libtool_files.sh OLD_GCC_VERSION (this is not the same case, but it's related, and if GCC is wrong libtool can also fail)
5) if everything fails comment: $CC, $FEATURES, $CFLAGS, $MAKEOPTS


1) I don't see any errors in my make.conf
2) did that, didn't help
3) did that, returns [1] i686-pc-linux-gnu-3.3.4 * --- so then i did gcc-config 1
4) did fix_libtool_files.sh 3.3.4 and it only returns
* Scanning libtool files for hardcoded gcc library paths...
did fix_libtool_files.sh 3.3 and it "fixed" a bunch of stuff - hope it didn't break anything
5) didn't do this one because I don't understand the why or what on doing that and how it will affect my system

After all this it still gives the same error.

My make.conf:
CFLAGS="-O3 -march=k8 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
USE="gtk gtk2 gnome qt kde mmx 3dnow sse usb opengl truetype apache2 alsa arts esd cdr dvd dvdr java ldap ooo-kde mad faad flac pda samba tiff wmf divx4linux avi spell oggvorbis speedx cups maildir gstreamer howl hal eds xinerama xosd 3dnowex mmx2 nvidia nptl cdparanoia audiofile xine"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

Some people mentioned downgrading binutils to binutils-2.15.92.0.2-r1 - that is what is already installed.

emerge info:
Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.6.9-gentoo-r13 i686)
=================================================================
System uname: 2.6.9-gentoo-r13 i686 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers: sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=k8 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=k8 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://mirrors.tds.net/gentoo http://cudlug.cudenver.edu/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex X acl alsa apache2 apm arts audiofile avi berkdb bitmap-fonts cdparanoia cdr crypt cups divx4linux dvd dvdr eds encode esd faad fam flacfoomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal howl imagemagick imlib ipv6 java jpeg junit kde ldap libwww mad maildir mikmod mmx mmx2 motif mozilla mpeg ncurses nls nptl nvidia oggvorbis ooo-kde opengl oss pam pda pdflib perl png python qt quicktime readline samba sdl speedx spell sse ssl svga tcpd tifftruetype usb wmf xine xinerama xml2 xmms xosd xv zlib video_cards_nvidia"
Comment 10 Jeremy Huddleston (RETIRED) gentoo-dev 2005-01-14 14:26:02 UTC
Jamie Kramer : I think your problem is bug #73435