Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 716230 - www-client/firefox-bin-74.0.1: XINPUT2 breaks clicking on top pixel on Xfce
Summary: www-client/firefox-bin-74.0.1: XINPUT2 breaks clicking on top pixel on Xfce
Status: RESOLVED DUPLICATE of bug 715604
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-04 20:20 UTC by Gleb
Modified: 2020-04-05 21:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb 2020-04-04 20:20:58 UTC
Recenlty this thing was enabled, and I now have this issue:
1) stable Xfce,
2) Firefox 74.0.1 (also was broken in some 74.0 revisions), title bar disabled, drag space disabled, window is maximized,

Sometimes, but not always, when I move a cursor to the very top, I cannot click on the very top pixel. It breaks the following actions: close tab with middle button click, open new tab with middle click, activate tab with left mouse click. It happens like this: move cursor to the very top (often without looking at it), don't move the cursor, click on mouse button. Expected action should be performed immediately, but I have to click several times and move cursor.

I did check my mouse, and it works properly, by deliberately positioning cursor in the middle of the tab, everything works in this case.

I hope it can be fixed. Also I don't understand why such important changes were made to the stable ebuild. There are a lot of commits to the ebuild recently and they were all marked as stable immediately.


Reproducible: Always
Comment 1 Thomas Deutschmann gentoo-dev Security 2020-04-05 21:30:16 UTC
Start firefox with MOZ_USE_XINPUT2=0 set and see if it makes any difference.

*** This bug has been marked as a duplicate of bug 715604 ***