Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 716036 - media-gfx/asymptote runtime-depends on net-libs/libtirpc if it was present at build time
Summary: media-gfx/asymptote runtime-depends on net-libs/libtirpc if it was present at...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrey Grozin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-03 16:00 UTC by July Tikhonov
Modified: 2020-04-03 19:34 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description July Tikhonov 2020-04-03 16:00:49 UTC
The easiest way to verify this is to run
ldd /usr/bin/asy
assuming that net-libs/libtirpc was present in the system when media-gfx/asymptote was built.

Also, you can see libtirpc detection in asymptote's configure.ac:
https://github.com/vectorgraphics/asymptote/blob/2.65/configure.ac#L350-L354

Also, I asked the author and he just added this library as an official requirement (in the upstream master repo):
https://github.com/vectorgraphics/asymptote/issues/148#issuecomment-608471260
https://github.com/vectorgraphics/asymptote/commit/decb4d5109744545082eb1843dcb2f1a52d4158c
and I don't expect that Gentoo will try to condition it with a USE flag (it seems possible, but not necessary, since libtirpc is a relatively basic library, as far as I can tell).

What to do with current versions of asymptote in Gentoo portage tree (2.61 and 2.62), I have no idea. I suppose that most asymptote installs have this unaccounted dependency…