Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 715722 - www-client/firefox - Problem with mouse scrolling
Summary: www-client/firefox - Problem with mouse scrolling
Status: RESOLVED DUPLICATE of bug 715604
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-01 07:50 UTC by Fulgurance
Modified: 2020-04-01 20:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge info (file_715722.txt,6.91 KB, text/plain)
2020-04-01 07:50 UTC, Fulgurance
Details
emerge --info (emerge.info.txt,7.38 KB, text/plain)
2020-04-01 09:10 UTC, Ivan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fulgurance 2020-04-01 07:50:59 UTC
Created attachment 628364 [details]
emerge info

Hello, i just would like to report problem with the last firefox source version (74.0-r2).

This problem occurred only with firefox. Sometimes, when i open new tab, scrolling page with mouse don't work.
Comment 1 Ivan 2020-04-01 09:09:36 UTC
I have problem with scrolling too.

Sometimes when I switch to another window without clicking on it (e.g. by scrolling in the taskbar) and in some other cases, scrolling doesn't work on page. Usually it can be fixed by clicking on page, but not always.

Also same thing occurs when I minimise to tray a *fullscreen* App (like DeaDBeeF or Telegram in fullscreen mode) by clicking in tray.

Here's 2 links to show that issue:
https://youtu.be/1uLRjDXi5Go
https://youtu.be/eLbAs2tJCbg

That happens only with firefox-74.0-r2. When I downgrade to 74.0-r1, everything is fine. Once I upgrade to 74.0-r2, the problem appears again.

P.S. keyboard up-arrow and down-arrow keep working

Firefox's info:
74.0-r2^td{tbz2}(00:45:06 31.03.2020)(clang custom-optimization eme-free gmp-autoupdate pulseaudio startup-notification system-av1 system-harfbuzz system-libevent system-webp wayland -bindist -custom-cflags -debug -geckodriver -hardened -hwaccel -jack -lto -pgo -screenshot -selinux -system-icu -system-jpeg -system-libvpx -system-sqlite -test -wifi CPU_FLAGS_ARM="-neon" CPU_FLAGS_X86="avx2" L10N="ru -ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -ia -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -ur -uz -vi -xh -zh-CN -zh-TW")
Comment 2 Ivan 2020-04-01 09:10:13 UTC
Created attachment 628370 [details]
emerge --info
Comment 3 Dmitry 2020-04-01 17:56:23 UTC
www-client/firefox-bin have that problem as well. It appeared after some recent release.

Steps to reproduce:
1. Open firefox window with some scrollable page on it
2. Switch focus to some other application window
3. Move mouse cursor back to firefox window (but don't switch focus to it)
4. Try to scroll with mouse wheel - it would not work (but it worked on previous releases)
Comment 4 Thomas Deutschmann gentoo-dev Security 2020-04-01 20:46:26 UTC

*** This bug has been marked as a duplicate of bug 715604 ***