Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 713768 - sys-boot/syslinux-6.04_pre1 : /.../wrapper.h: error: unknown type name uint8_t
Summary: sys-boot/syslinux-6.04_pre1 : /.../wrapper.h: error: unknown type name uint8_t
Status: RESOLVED DUPLICATE of bug 626952
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo musl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: missing-musl-includes
  Show dependency tree
 
Reported: 2020-03-21 11:13 UTC by Toralf Förster
Modified: 2020-07-30 18:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.06 KB, text/plain)
2020-03-21 11:13 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,226.31 KB, text/plain)
2020-03-21 11:13 UTC, Toralf Förster
Details
environment (environment,76.82 KB, text/plain)
2020-03-21 11:13 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,19.17 KB, application/x-bzip)
2020-03-21 11:13 UTC, Toralf Förster
Details
sys-boot:syslinux-6.04_pre1:20200321-072645.log (sys-boot:syslinux-6.04_pre1:20200321-072645.log,966.26 KB, text/plain)
2020-03-21 11:13 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,48.78 KB, application/x-bzip)
2020-03-21 11:13 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-03-21 11:13:17 UTC
x86_64-gentoo-linux-musl-gcc /var/tmp/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi/wrapper.c -o wrapper
In file included from /var/tmp/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi/wrapper.c:25:
/var/tmp/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi/wrapper.h:30:19: error: unknown type name uint8_t
   30 | #define __uint8_t uint8_t
      |                   ^~~~~~~
/var/tmp/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi/wrapper.h:44:2: note: in expansion of macro __uint8_t

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_musl-20200316-165821

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-gentoo-linux-musl-9.3.0 *
clang version 10.0.0 
Target: x86_64-gentoo-linux-musl
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.41.1 *

timestamp of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sat Mar 21 01:38:36 UTC 2020
/var/db/repos/musl	Sat Mar 21 03:09:12 UTC 2020

emerge -qpvO sys-boot/syslinux
[ebuild  N    ] sys-boot/syslinux-6.04_pre1  USE="-custom-cflags"
Comment 1 Toralf Förster gentoo-dev 2020-03-21 11:13:20 UTC
Created attachment 623724 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-03-21 11:13:23 UTC
Created attachment 623726 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-03-21 11:13:25 UTC
Created attachment 623728 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-03-21 11:13:28 UTC
Created attachment 623730 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-03-21 11:13:31 UTC
Created attachment 623732 [details]
sys-boot:syslinux-6.04_pre1:20200321-072645.log
Comment 6 Toralf Förster gentoo-dev 2020-03-21 11:13:34 UTC
Created attachment 623734 [details]
temp.tbz2
Comment 7 Sam James archtester gentoo-dev Security 2020-03-31 19:29:24 UTC
maybe patch: https://git.alpinelinux.org/aports/tree/main/syslinux/fix-sysmacros.patch

can't see anything explicitly related to this: https://git.alpinelinux.org/aports/tree/main/syslinux?h=master
Comment 8 Pacho Ramos gentoo-dev 2020-07-30 18:14:07 UTC

*** This bug has been marked as a duplicate of bug 626952 ***