Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 713664 - net-analyzer/slurm-0.4.3 : /.../os.h: fatal error: sys/sysctl.h: No such file or directory
Summary: net-analyzer/slurm-0.4.3 : /.../os.h: fatal error: sys/sysctl.h: No such file...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo musl team
URL:
Whiteboard:
Keywords: PATCH
: 770388 (view as bug list)
Depends on:
Blocks: missing-musl-includes 757054
  Show dependency tree
 
Reported: 2020-03-20 17:07 UTC by Toralf Förster
Modified: 2021-08-05 03:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.58 KB, text/plain)
2020-03-20 17:07 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,204.18 KB, text/plain)
2020-03-20 17:08 UTC, Toralf Förster
Details
environment (environment,112.16 KB, text/plain)
2020-03-20 17:08 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,18.09 KB, application/x-bzip)
2020-03-20 17:08 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,5.08 KB, application/x-bzip)
2020-03-20 17:08 UTC, Toralf Förster
Details
net-analyzer:slurm-0.4.3:20200320-162258.log (net-analyzer:slurm-0.4.3:20200320-162258.log,6.59 KB, text/plain)
2020-03-20 17:08 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,26.94 KB, application/x-bzip)
2020-03-20 17:08 UTC, Toralf Förster
Details
Update location of header file (sysctl.patch,347 bytes, patch)
2020-09-08 01:37 UTC, rypervenche
Details | Diff
fixed diff to broken sysctl.h location (sysctl.patch,353 bytes, patch)
2020-12-10 01:38 UTC, alex Mezey
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-03-20 17:07:56 UTC
/usr/bin/x86_64-gentoo-linux-musl-gcc -D_HAVE_NCURSES   -DNDEBUG -O2 -pipe -march=native -fno-common -falign-functions=32:25:16   -o CMakeFiles/slurm.dir/slurm.c.o -c /var/tmp/portage/net-analyzer/slurm-0.4.3/work/slurm-upstream/slurm.c
In file included from /var/tmp/portage/net-analyzer/slurm-0.4.3/work/slurm-upstream/slurm.c:37:
/var/tmp/portage/net-analyzer/slurm-0.4.3/work/slurm-upstream/os.h:180:10: fatal error: sys/sysctl.h: No such file or directory
  180 | #include <sys/sysctl.h>
      |          ^~~~~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_musl-20200316-165821

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-gentoo-linux-musl-9.3.0 *
clang version 10.0.0 
Target: x86_64-gentoo-linux-musl
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.41.1 *

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Wed, 18 Mar 2020 13:38:27 +0000
emerge -qpvO net-analyzer/slurm
[ebuild  N    ] net-analyzer/slurm-0.4.3
Comment 1 Toralf Förster gentoo-dev 2020-03-20 17:07:59 UTC
Created attachment 623352 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-03-20 17:08:02 UTC
Created attachment 623354 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-03-20 17:08:04 UTC
Created attachment 623356 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-03-20 17:08:07 UTC
Created attachment 623358 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-03-20 17:08:10 UTC
Created attachment 623360 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-03-20 17:08:12 UTC
Created attachment 623362 [details]
net-analyzer:slurm-0.4.3:20200320-162258.log
Comment 7 Toralf Förster gentoo-dev 2020-03-20 17:08:15 UTC
Created attachment 623364 [details]
temp.tbz2
Comment 9 rypervenche 2020-09-08 01:37:21 UTC
Created attachment 659030 [details, diff]
Update location of header file

This replaces sys/sysctl.h with linux/sysctl.h and it compiles correctly on my end.
Comment 10 alex Mezey 2020-12-10 01:38:40 UTC
Created attachment 677518 [details, diff]
fixed diff to broken sysctl.h location
Comment 11 Larry the Git Cow gentoo-dev 2021-02-13 09:54:55 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6c9d623b817d83875351c916cca8121454e249b6

commit 6c9d623b817d83875351c916cca8121454e249b6
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2021-02-13 09:54:34 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-02-13 09:54:34 +0000

    net-analyzer/slurm: Fix includes
    
    * Port to EAPI 7
    * Use patch from Alpine
    
    Bug: https://bugs.gentoo.org/757054
    Closes: https://bugs.gentoo.org/713664
    Package-Manager: Portage-3.0.14, Repoman-3.0.2
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../slurm/files/slurm-0.4.3-fix-includes.patch     | 22 ++++++++++++++
 net-analyzer/slurm/slurm-0.4.3.ebuild              | 34 +++++++++-------------
 2 files changed, 36 insertions(+), 20 deletions(-)
Comment 12 Sam James archtester gentoo-dev Security 2021-08-05 03:21:42 UTC
*** Bug 770388 has been marked as a duplicate of this bug. ***