Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 712260 (CVE-2020-10018, CVE-2020-11793, CVE-2020-3885, CVE-2020-3894, CVE-2020-3895, CVE-2020-3897, CVE-2020-3899, CVE-2020-3900, CVE-2020-3901, CVE-2020-3902, WSA-2020-0003, WSA-2020-0004, WSA-2020-0005) - <net-libs/webkit-gtk-2.28.2: Multiple vulnerabilities (CVE-2020-{3885,3894,3895,3897,3899,3900,3901,3902,10018,11793})
Summary: <net-libs/webkit-gtk-2.28.2: Multiple vulnerabilities (CVE-2020-{3885,3894,38...
Status: RESOLVED FIXED
Alias: CVE-2020-10018, CVE-2020-11793, CVE-2020-3885, CVE-2020-3894, CVE-2020-3895, CVE-2020-3897, CVE-2020-3899, CVE-2020-3900, CVE-2020-3901, CVE-2020-3902, WSA-2020-0003, WSA-2020-0004, WSA-2020-0005
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Security
URL:
Whiteboard: A2 [glsa+ cve]
Keywords: CC-ARCHES
Depends on: 704182 717888
Blocks:
  Show dependency tree
 
Reported: 2020-03-12 18:00 UTC by Sam James
Modified: 2020-07-19 11:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam James gentoo-dev Security 2020-03-12 18:00:08 UTC
Description:
"Processing maliciously crafted web content may lead to arbitrary code execution. A memory corruption issue (use-after-free) was addressed with improved memory handling."

Affects:
"Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0."

Bug (restricted): https://bugs.webkit.org/show_bug.cgi?id=204342
Patch: https://trac.webkit.org/changeset/257292/webkit
Comment 1 Sam James gentoo-dev Security 2020-04-16 00:43:57 UTC
@maintainer(s): ping
Comment 2 Sam James gentoo-dev Security 2020-04-16 13:12:17 UTC
2) CVE-2020-11793

   Versions affected: WebKitGTK before 2.28.1 and WPE WebKit before
   2.28.1.
   Credit to Cim Stordal of Cognite.
   Impact: Processing maliciously crafted web content may lead to
   arbitrary code execution or application crash (denial of service).
   Description: A memory corruption issue (use-after-free) was
   addressed with improved memory handling.


URL: https://webkitgtk.org/security/WSA-2020-0004.html
Comment 3 Sam James gentoo-dev Security 2020-04-17 18:48:48 UTC
We've discussed stabilisation: some build failures need poking at first.

[updating summary/whiteboard]
Comment 4 GLSAMaker/CVETool Bot gentoo-dev 2020-04-21 21:37:38 UTC
CVE-2020-11793 (https://nvd.nist.gov/vuln/detail/CVE-2020-11793):
  A use-after-free issue exists in WebKitGTK before 2.28.1 and WPE WebKit
  before 2.28.1 via crafted web content that allows remote attackers to
  execute arbitrary code or cause a denial of service (memory corruption and
  application crash).
Comment 5 Sam James gentoo-dev Security 2020-04-28 04:30:49 UTC
NOTE: These new CVEs need to be added to CVETool, had an error so cannot do it yet.

From https://wpewebkit.org/security/WSA-2020-0005.html

    CVE-2020-3885
        Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
        Credit to Ryan Pickren (ryanpickren.com).
        Impact: A file URL may be incorrectly processed. Description: A logic issue was addressed with improved restrictions.

    CVE-2020-3894
        Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
        Credit to Sergei Glazunov of Google Project Zero.
        Impact: An application may be able to read restricted memory. Description: A race condition was addressed with additional validation.

    CVE-2020-3895
        Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
        Credit to grigoritchy.
        Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A memory corruption issue was addressed with improved memory handling.

    CVE-2020-3897
        Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
        Credit to Brendan Draper (@6r3nd4n) working with Trend Micro’s Zero Day Initiative.
        Impact: A remote attacker may be able to cause arbitrary code execution. Description: A type confusion issue was addressed with improved memory handling.

    CVE-2020-3899
        Versions affected: WebKitGTK before 2.28.2 and WPE WebKit before 2.28.2.
        Credit to OSS-Fuzz.
        Impact: A remote attacker may be able to cause arbitrary code execution. Description: A memory consumption issue was addressed with improved memory handling.

    CVE-2020-3900
        Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
        Credit to Dongzhuo Zhao working with ADLab of Venustech.
        Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A memory corruption issue was addressed with improved memory handling.

    CVE-2020-3901
        Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
        Credit to Benjamin Randazzo (@____benjamin).
        Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A type confusion issue was addressed with improved memory handling.

    CVE-2020-3902
        Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
        Credit to Yiğit Can YILMAZ (@yilmazcanyigit).
        Impact: Processing maliciously crafted web content may lead to a cross site scripting attack. Description: An input validation issue was addressed with improved input validation.
Comment 6 Sam James gentoo-dev Security 2020-04-28 04:31:58 UTC
@maintainer(s), please let us know if any progress can be made on bug 717888.
Comment 7 Sam James gentoo-dev Security 2020-04-28 05:26:03 UTC
Needs bump to 2.28.2.
Comment 8 Larry the Git Cow gentoo-dev 2020-05-09 20:40:14 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cad04281bde21306bed8efe2fb68e6cc955bdab4

commit cad04281bde21306bed8efe2fb68e6cc955bdab4
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2020-05-09 19:16:08 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2020-05-09 20:39:33 +0000

    net-libs/webkit-gtk: bump to 2.28.2, fix various build issues
    
    Fix build issue when ccache is found.
    Try to fix various opengl without X build issues.
    USE="gstreamer X" requires gst-plugins-base[X].
    
    Includes a few patches that have been marked as 2.28.3 candidates by
    upstream.
    
    Closes: https://bugs.gentoo.org/717888
    Bug: https://bugs.gentoo.org/712260
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 net-libs/webkit-gtk/Manifest                       |   1 +
 .../webkit-gtk/files/2.28.2-fix-ppc64-JSC.patch    |  59 +++++
 .../files/2.28.2-fix-yelp-desktopless-build.patch  |  53 ++++
 .../files/2.28.2-opengl-without-X-fixes.patch      |  53 ++++
 .../files/2.28.2-use-gst-audiointerleave.patch     |  55 ++++
 net-libs/webkit-gtk/webkit-gtk-2.28.2.ebuild       | 291 +++++++++++++++++++++
 6 files changed, 512 insertions(+)
Comment 9 Mart Raudsepp gentoo-dev 2020-05-09 20:50:31 UTC
Going to give this a day or two in ~arch before requesting stabling, as I try to test more USE flag combinations with the bump+patchset meanwhile myself too.
Comment 10 Mart Raudsepp gentoo-dev 2020-05-12 21:33:37 UTC
I can't reproduce various failures reliably anymore - I hope it was just a memory problem with MAKEOPTS=-j40 or something. One build issue I did find (with USE=-jumbo-build, probably together with USE=-gstreamer), which I have fixed now by my own testing.
So lets give this a shot at stabling this new 2.28 series now.
Comment 11 Agostino Sarubbo gentoo-dev 2020-05-13 13:18:03 UTC
amd64 stable
Comment 12 Agostino Sarubbo gentoo-dev 2020-05-13 13:19:50 UTC
x86 stable
Comment 13 Sam James gentoo-dev Security 2020-05-14 21:36:28 UTC
arm64 stable

@maintainer(s), please cleanup
Comment 14 Mart Raudsepp gentoo-dev 2020-05-15 12:37:08 UTC
Can't cleanup with bug 704182 still open. Removed 2.28.1, but rest kept (in case some on bug 704182 can go to at least the 2.26 series, if not 2.28 yet).
Comment 15 GLSAMaker/CVETool Bot gentoo-dev 2020-06-13 01:42:06 UTC
This issue was resolved and addressed in
 GLSA 202006-08 at https://security.gentoo.org/glsa/202006-08
by GLSA coordinator Aaron Bauman (b-man).
Comment 16 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2020-06-13 01:42:55 UTC
re-opened for cleanup
Comment 17 Larry the Git Cow gentoo-dev 2020-07-19 06:00:26 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5006f73937044695f6a1317de58ef80d12b19b7a

commit 5006f73937044695f6a1317de58ef80d12b19b7a
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2020-07-19 05:58:49 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2020-07-19 05:59:37 +0000

    net-libs/webkit-gtk: remove old
    
    Bug: https://bugs.gentoo.org/699156
    Bug: https://bugs.gentoo.org/712260
    Bug: https://bugs.gentoo.org/732104
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 net-libs/webkit-gtk/Manifest                       |   3 -
 .../files/2.26.2-fix-arm-non-unified-build.patch   |  27 --
 net-libs/webkit-gtk/files/2.26.3-fix-gtk-doc.patch |  27 --
 .../webkit-gtk/files/2.28.2-fix-ppc64-JSC.patch    |  59 -----
 .../files/2.28.2-fix-yelp-desktopless-build.patch  |  53 ----
 .../files/2.28.2-use-gst-audiointerleave.patch     |  55 ----
 .../files/webkit-gtk-2.24.4-icu-65.patch           |  53 ----
 net-libs/webkit-gtk/metadata.xml                   |   4 -
 net-libs/webkit-gtk/webkit-gtk-2.24.4.ebuild       | 283 --------------------
 net-libs/webkit-gtk/webkit-gtk-2.26.4-r1.ebuild    | 286 --------------------
 net-libs/webkit-gtk/webkit-gtk-2.28.2.ebuild       | 293 ---------------------
 11 files changed, 1143 deletions(-)
Comment 18 NATTkA bot gentoo-dev 2020-07-19 06:05:25 UTC
Unable to check for sanity:

> no match for package: net-libs/webkit-gtk-2.28.2
Comment 19 Sam James gentoo-dev Security 2020-07-19 11:25:53 UTC
All done, thanks. Closing.