Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 71110 - degrading hotplug, and moving stuff to coldplug broke all init.d-scripts, that depend on hotplug
Summary: degrading hotplug, and moving stuff to coldplug broke all init.d-scripts, tha...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Greg Kroah-Hartman (RETIRED)
Depends on:
Reported: 2004-11-13 18:25 UTC by Sven
Modified: 2004-11-15 15:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sven 2004-11-13 18:25:55 UTC

well, the subject says it all:
/etc/init.d/net.eth0 for example used to depend on hotplug. All init.d-scripts that used to depend on hotplug should now depend on coldplug, but there doesn't seem to be an update for baselayout etc.

The current state is inkonsistent. Do something ;-)

Reproducible: Always
Steps to Reproduce:
Comment 1 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-11-15 12:31:41 UTC
net.eth* now lists coldplug.

Other packages are following suit.

Please create new bugs based on each package that you find not doing this
Comment 2 Sven 2004-11-15 12:40:48 UTC
So for which baselayout versions has this been fixed?
Comment 3 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-11-15 14:48:28 UTC
Don't know the versions, shows up on my boxes running ~x86
Comment 4 Sven 2004-11-15 14:52:40 UTC
Since coldplug is stable, you should fix all stable baselayouts.
You cannot leave all x86-system (not ~x86) out there in a broken state.
Comment 5 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-11-15 14:54:42 UTC
Again, please file bugs against the individual packages that are not
properly adding coldplug to their dependancies, so we can know which
ones to fix up.
Comment 6 SpanKY gentoo-dev 2004-11-15 14:54:58 UTC
it's not any worse than before

hotplug has pretty broken / doing nothing in stable
Comment 7 Sven 2004-11-15 14:57:30 UTC
Well, afaik, baselayout-1.9.4-r6 is still broken.

@vapier: what do you mean? hotplug worked pretty good before it became a no-op.
Comment 8 Sven 2004-11-15 15:02:28 UTC
In addition, a good thing would be, if coldplug depends on a version of baselayout that has been fixed init.d-scripts, since it is essential that users that update to coldplug also have an updated baselayout installed.
Comment 9 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-11-15 15:19:32 UTC
The ability for hotplug to load modules properly has _never_ worked well, you just were very lucky :)
Comment 10 Sven 2004-11-15 15:24:25 UTC
So why was hotplug stable (keyword x86) than?

I'm still waiting for the CVS on to refrlect the changes you made, so that i can finally check which versions of baselayout were fixed. I still would recomm it to fix at least the baselayout-ebuilds that is stable on x86 and amd64 if they aren't already.
Comment 11 Seemant Kulleen (RETIRED) gentoo-dev 2004-11-15 15:34:37 UTC
I'd have to agree with Sven here.  That's a dangling dependency situation if coldplug is stable and dependent upon an unstable baselayout.