Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 710284 - kde-apps/kontact-19.12.2 should depend on kde-apps/kmail-account-wizard
Summary: kde-apps/kontact-19.12.2 should depend on kde-apps/kmail-account-wizard
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-20 10:03 UTC by rene
Modified: 2020-02-20 14:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rene 2020-02-20 10:03:14 UTC
kcontact initial start requires to create account and immediately fails with comand line error: "Could not find the program 'accountwizard'"

Solved by installing "kde-apps/kmail-account-wizard", which is missing in dependencies.
Comment 1 Andreas Sturmlechner gentoo-dev 2020-02-20 13:29:35 UTC
Please note that kmail depends on kmail-account-wizard already.

What part of kontact required you to create an account while you did not even have kmail installed?
Comment 2 rene 2020-02-20 14:19:55 UTC
just installed kontact. Have not (yet) installed kmail.

After starting kontact, there is the option "Setup your Accounts
Prepare Kontact for use" which fails immediately without kmail-account-wizard.

Didn't checked it further, because the (only) offer after installing kmail-account-wizard was setting up "Tine2.0" which failed again with "QFormBuilder was unable to create a custom widget of the class 'KPasswordLineEdit'; defaulting to base class 'QWidget'."

Maybe kontact should have kmail as dependency? (I have no real idea about the potentials and functionalities of kontact and if it is useful at all without kmail, mainly tried to test it)

-----------------
Now tried the same with installed kmail. Starting kontact now does not display any introductory window, just asks me to import data from other installed email clients and after selection warns me with "Close KMail before importing data. Some plugins will modify KMail config file." - not having KMail opened at all.