Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 70928 - Libraries not installed (can't copy linked files?)
Summary: Libraries not installed (can't copy linked files?)
Status: RESOLVED DUPLICATE of bug 71694
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Stuart Herbert (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 63757
  Show dependency tree
 
Reported: 2004-11-12 00:29 UTC by J R
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Diff of modified nx-x11-1.4.0-r2.ebuild and original (nx-x11-1.4.0-r2.ebuild.diff,576 bytes, patch)
2004-11-12 00:35 UTC, J R
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description J R 2004-11-12 00:29:42 UTC
Hi- installing nx-x11 (1.4-rc2) silently fails (i.e. doesn't bomb out) when trying to copy the various libs to the /var/tmp/portage/nx-x11/image directory.  Running the ebuild manually I noticed link failures.  It was easy to fix- I simply changed the ebuild to point to the 'real' libraries and not the linked filenames- details below.

Reproducible: Always
Steps to Reproduce:
1. ebuild the ebuild, watch the output of the install stage.


Actual Results:  
Appears to be installed, but no package exports libXcompext, etc.

Expected Results:  
Installed the libraries.

Here is my working src_install() function:
src_install() {
	into /usr/NX

	dobin programs/Xserver/nxagent
	dobin programs/nxauth/nxauth
	dobin ../nxviewer/nxviewer/nxviewer
	dobin ../nxviewer/nxpasswd/nxpasswd
	dobin ../nxdesktop/nxdesktop

	dolib ../nxcomp/libXcomp.so.1.4.0
	dolib ../nxcompext/libXcompext.so.1.4.0
	dolib lib/X11/libX11.so.6.2
	dolib lib/Xext/libXext.so.6.4
	dolib lib/Xrender/libXrender.so.1.2

	preplib /usr/NX

	insinto /usr/X11R6/include
	doins ../nxcomp/NX.h

	dodir /var/lib/nxserver

	return

	# nxesd support will have to wait for a later release

	cd ../nxesd
	emake DESTDIR=${D} install || die "unable to install nxesd"
}
Comment 1 J R 2004-11-12 00:35:01 UTC
Created attachment 43765 [details, diff]
Diff of modified nx-x11-1.4.0-r2.ebuild and original

generated with diff -u
Comment 2 Stuart Herbert (RETIRED) gentoo-dev 2005-01-02 01:32:38 UTC

*** This bug has been marked as a duplicate of 71694 ***