Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708692 - app-portage/layman-2.4.2-r2 : src_prepare(): DISTUTILS_USE_SETUPTOOLS value is probably incorrect
Summary: app-portage/layman-2.4.2-r2 : src_prepare(): DISTUTILS_USE_SETUPTOOLS value i...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Layman Overlay Manager project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DISTUTILS_USE_SETUPTOOLS 710650
  Show dependency tree
 
Reported: 2020-02-08 09:07 UTC by CaptainBlood
Modified: 2021-09-10 10:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description CaptainBlood 2020-02-08 09:07:37 UTC
installs with such a strange warning.


Emerging (1 of 1) app-portage/layman-2.4.2-r2::gentoo
 * layman-2.4.2.tar.gz BLAKE2B SHA512 size ;-) ...                                                                                    [ ok ]
>>> Unpacking source...
>>> Unpacking layman-2.4.2.tar.gz to /var/tmp/portage/app-portage/layman-2.4.2-r2/work
>>> Source unpacked in /var/tmp/portage/app-portage/layman-2.4.2-r2/work
>>> Preparing source in /var/tmp/portage/app-portage/layman-2.4.2-r2/work/layman-2.4.2 ...
 * DISTUTILS_USE_SETUPTOOLS value is probably incorrect
 *   value:    DISTUTILS_USE_SETUPTOOLS=bdepend (default?)
 *   expected: DISTUTILS_USE_SETUPTOOLS=no
python3.6 setup.py setup_plugins
running setup_plugins
 * Adjusting to prefix /
 *   layman.cfg ...                                                                                                                   [ ok ]
 *   config.py ...                                                                                                                    [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-portage/layman-2.4.2-r2/work/layman-2.4.2 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-portage/layman-2.4.2-r2/work/layman-2.4.2 ...
 * python3_6: running distutils-r1_run_phase distutils-r1_python_compile
python3.6 setup.py build -j 3
running build
running build_py
-------------------------------------------------------------------------------
emerge --info layman
FEATURES variable contains unknown value(s): distcc-pump
Portage 2.3.84 (python 3.6.9-final-0, default/linux/amd64/17.1, gcc-9.2.0, glibc-2.29-r7, 4.19.97-gentoo-classic x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.97-gentoo-classic-x86_64-Intel-R-_Core-TM-_i3-6100_CPU_@_3.70GHz-with-gentoo-2.6
KiB Mem:     3941140 total,    596788 free
KiB Swap:    8048528 total,   7706136 free
Timestamp of repository gentoo: Sat, 08 Feb 2020 08:15:01 +0000
Head commit of repository gentoo: d21af373b9e53f5fc87c722e2d6ef18b4c4d0db5

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17::gentoo, 3.6.9::gentoo, 3.7.5-r1::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.2.0-r3::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r7::gentoo
Repositories:

gnu-elpa
    location: /var/lib/layman/gnu-elpa
    masters: gentoo
    priority: -100001

melpa
    location: /var/lib/layman/melpa
    masters: gnu-elpa gentoo
    priority: -100001

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

local-repo
    location: /var/db/repos/local-repo
    masters: gentoo

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=skylake -mtune=skylake  -O2             -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.3/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=skylake -mtune=skylake  -O2             -pipe    "
DISTDIR="/var/cache/distfiles"
EMERGE_DEFAULT_OPTS="--alert y 			--alphabetical 			--ask-enter-invalid 			--autounmask y  	--autounmask-only n  			--autounmask-unrestricted-atoms y  			--autounmask-write y 			--misspell-suggestions n 			--noconfmem 			--nospinner   			--tree 			--with-bdeps y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=skylake -mtune=skylake  -O2             -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distcc-pump distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms split-elog strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=skylake -mtune=skylake  -O2             -pipe"
GENTOO_MIRRORS="http://ftp.free.fr/mirrors/ftp.gentoo.org/ https://mirrors.evowise.com/gentoo/ http://mirror.dkm.cz/gentoo/ http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ http://mirror.netcologne.de/gentoo/ http://mirror.leaseweb.com/gentoo/ http://mirror.bytemark.co.uk/gentoo/ http://gentoo.mirror.web4u.cz/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="fr_FR.utf8"
LDFLAGS="  -Wl,-O1       -Wl,-fuse-ld=bfd  -Wl,--enable-new-dtags  -march=skylake -mtune=skylake  -O2             -pipe "
LINGUAS="fr"
MAKEOPTS="-j3 -l3"
PKGDIR="/var/cache/binpkgs"
PORTAGE_COMPRESS="lzma"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="amd64 asm minimal split-usr" ABI_X86="64" ALSA_CARDS="hda-intel" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GRUB_PLATFORMS="pc" INPUT_DEVICES="libinput" KERNEL="linux" L10N="fr" PHP_TARGETS="php7-3" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_6 python3_7" QEMU_USER_TARGETS="aarch64" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="intel i965"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-portage/layman-2.4.2-r2::gentoo was built with the following:
USE="-bazaar -cvs -darcs g-sorcery git -gpg -mercurial -sqlite -squashfs -subversion -sync-plugin-portage -test" ABI_X86="(64)" PYTHON_TARGETS="-python2_7 python3_6 -python3_7"
FEATURES="ebuild-locks assume-digests distcc-pump multilib-strict userfetch unmerge-logs unmerge-orphans protect-owned split-elog sfperms config-protect-if-modified fixlafiles distlocks unknown-features-warn network-sandbox pid-sandbox merge-sync sandbox userpriv parallel-fetch news binpkg-docompress binpkg-dostrip preserve-libs strict ipc-sandbox usersync usersandbox binpkg-logs"


Reproducible: Always
Comment 1 Brian Dolbec gentoo-dev 2020-04-24 19:10:42 UTC
This ebuild does have DISTUTILS_USE_SETUPTOOLS=no

It was liklely due to an eclass default setting.  That variable assignment was only added 2020-04-15 14:57:27 -0400