Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708502 - media-gfx/gimp-2.10.4 crashes when pasting images from gimp outside of gimp
Summary: media-gfx/gimp-2.10.4 crashes when pasting images from gimp outside of gimp
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Sergey Torokhov
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-06 21:50 UTC by Michał Dec
Modified: 2020-02-10 05:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info gimp (emerge.info,7.64 KB, text/plain)
2020-02-06 21:51 UTC, Michał Dec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Dec 2020-02-06 21:50:40 UTC
gimp crashes when the user copies and image and then tries to paste it in another program.

Reproducible: Always

Steps to Reproduce:
1. Open gimp.
2. Create an image.
3. Copy the image.
4. Paste it to another program.
Actual Results:  
gimp crashed.

Expected Results:  
Image should be pasted.
Comment 1 Michał Dec 2020-02-06 21:51:27 UTC
Created attachment 612094 [details]
emerge --info gimp
Comment 2 Maciej Barć 2020-02-07 00:41:28 UTC
I had the similar error.
It happened every time when using a clipboard for images.
When I turned off storing images in a 3-rd party clipboard program it only crashed when pasting a image to Telegram (net-im/telegram-desktop-bin)

Gtk-Message: 01:39:04.364: Failed to load module "appmenu-gtk-module"
using gegl copy
The program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 305786 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(gimp-org-script-fu:3507): LibGimpBase-WARNING **: 01:40:42.520: gimp-org-script-fu: gimp_wire_read(): error
Comment 3 Michał Dec 2020-02-07 08:20:56 UTC
Reproducing the bug with gimp running in gdb yielded the same message as #2. There's already 2 of us, so it's fair to say this bug is confirmed.
Comment 4 Sergey Torokhov 2020-02-10 05:50:12 UTC
This is already known upstream bug (and similar):

1. https://gitlab.gnome.org/GNOME/gimp/issues/789

2. https://gitlab.gnome.org/GNOME/gimp/issues/2733

3. https://gitlab.gnome.org/GNOME/gimp/issues/3295

I could only confirm in upstream bugzilla that it still reproduces because it's not gentoo specific issue.