Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708408 - net-irc/irc-server-2.11.1_p1-r4 : fails to build with -fno-common or gcc-10
Summary: net-irc/irc-server-2.11.1_p1-r4 : fails to build with -fno-common or gcc-10
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PMASKED
: 720992 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-02-05 20:18 UTC by Toralf Förster
Modified: 2020-09-30 15:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.38 KB, text/plain)
2020-02-05 20:18 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,80.85 KB, text/plain)
2020-02-05 20:18 UTC, Toralf Förster
Details
environment (environment,45.52 KB, text/plain)
2020-02-05 20:18 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.70 KB, application/x-bzip)
2020-02-05 20:18 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,11.60 KB, application/x-bzip)
2020-02-05 20:18 UTC, Toralf Förster
Details
net-irc:irc-server-2.11.1_p1-r4:20200205-195342.log (net-irc:irc-server-2.11.1_p1-r4:20200205-195342.log,28.06 KB, text/plain)
2020-02-05 20:18 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-02-05 20:18:43 UTC
./version.c.SH
Building version.c...
gcc -O2 -pipe -march=native -fno-common -I. -I../ircd -I../common  -c -o version.o version.c
gcc -Wl,-O1 -Wl,--as-needed -o ircd bsd.o dbuf.o packet.o send.o match.o parse.o support.o version.o channel.o class.o hash.o ircd.o list.o res.o s_auth.o s_bsd.o s_conf.o s_debug.o s_err.o s_id.o s_misc.o s_numeric.o s_send.o s_serv.o s_service.o s_user.o s_zip.o whowas.o res_init.o res_comp.o res_mkquery.o -lz -lm -lnsl -lcrypt 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: dbuf.o:(.bss+0x20): multiple definition of `mydummy2'; bsd.o:(.bss+0x0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: dbuf.o:(.bss+0xa0): multiple definition of `mydummy'; bsd.o:(.bss+0x80): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib-test-20200203-215003

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)




ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Wed, 05 Feb 2020 18:52:51 +0000

emerge -qpvO net-irc/irc-server
[ebuild  N    ] net-irc/irc-server-2.11.1_p1-r4  USE="ipv6 zlib"
Comment 1 Toralf Förster gentoo-dev 2020-02-05 20:18:45 UTC
Created attachment 612006 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-02-05 20:18:48 UTC
Created attachment 612008 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-02-05 20:18:51 UTC
Created attachment 612010 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-02-05 20:18:54 UTC
Created attachment 612012 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-02-05 20:18:56 UTC
Created attachment 612014 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-02-05 20:18:59 UTC
Created attachment 612016 [details]
net-irc:irc-server-2.11.1_p1-r4:20200205-195342.log
Comment 7 Sam James archtester gentoo-dev Security 2020-05-04 20:27:37 UTC
*** Bug 720992 has been marked as a duplicate of this bug. ***
Comment 8 Larry the Git Cow gentoo-dev 2020-08-30 01:05:09 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=01100e28006a203f7c11a353eb66b59f08de80ff

commit 01100e28006a203f7c11a353eb66b59f08de80ff
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2020-08-30 01:04:13 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-08-30 01:05:00 +0000

    profiles/package.mask: last-rite net-irc/irc-server
    
    Bug: https://bugs.gentoo.org/633346
    Bug: https://bugs.gentoo.org/708408
    Bug: https://bugs.gentoo.org/716264
    Signed-off-by: Sam James <sam@gentoo.org>

 profiles/package.mask | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 9 Larry the Git Cow gentoo-dev 2020-09-30 15:17:45 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ca36de6c32adb446067d48d898a524dc03d905c2

commit ca36de6c32adb446067d48d898a524dc03d905c2
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2020-09-30 15:10:07 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-09-30 15:17:14 +0000

    net-irc/irc-server: remove last-rited package
    
    Bug: https://bugs.gentoo.org/633346
    Bug: https://bugs.gentoo.org/708408
    Bug: https://bugs.gentoo.org/716264
    Signed-off-by: Sam James <sam@gentoo.org>

 net-irc/irc-server/Manifest                       |   1 -
 net-irc/irc-server/files/2.10.3_p3-gentoo.patch   |  11 ---
 net-irc/irc-server/files/ircd.confd               |  10 --
 net-irc/irc-server/files/ircd.rc                  |  30 ------
 net-irc/irc-server/irc-server-2.11.1_p1-r4.ebuild | 110 ----------------------
 net-irc/irc-server/metadata.xml                   |   5 -
 profiles/package.mask                             |   1 -
 7 files changed, 168 deletions(-)