Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 708304 - net-wireless/chirp depends on dev-python/pygtk (needs py3 port)
Summary: net-wireless/chirp depends on dev-python/pygtk (needs py3 port)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2020-09-21
Assignee: Rick Farina (Zero_Chaos)
URL: https://chirp.danplanet.com/issues/7431
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: py3-tracker, python-3-incompatible pygtk-removal
  Show dependency tree
 
Reported: 2020-02-04 23:33 UTC by 0xC0ncord
Modified: 2020-09-21 06:07 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Test ebuild to check Python 3 compatibility (chirp-20200603.ebuild,1.13 KB, text/plain)
2020-06-19 11:58 UTC, 0xC0ncord
Details
build-20200619.log (build.log,3.15 KB, text/x-log)
2020-06-19 11:59 UTC, 0xC0ncord
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 0xC0ncord 2020-02-04 23:33:55 UTC
Bugs #694800 and #706462 don't seem to be tracking this package. Upstream bug: https://chirp.danplanet.com/issues/7431

Reproducible: Always
Comment 1 Andreas Sturmlechner gentoo-dev 2020-03-22 23:18:54 UTC
Seems like porting is indeed ongoing.
Comment 2 Andreas Sturmlechner gentoo-dev 2020-06-16 21:55:54 UTC
Any news here?
Comment 3 0xC0ncord 2020-06-19 11:58:13 UTC
Created attachment 645246 [details]
Test ebuild to check Python 3 compatibility
Comment 4 0xC0ncord 2020-06-19 11:59:09 UTC
Created attachment 645248 [details]
build-20200619.log
Comment 5 0xC0ncord 2020-06-19 11:59:56 UTC
Just to test, I tried to build this package with Python 3 support, but it fails early when running into incompatible Python 2 code. The ebuild and build log are attached.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-08-03 17:54:48 UTC
The py3 branch has seen no activity since February.  It doesn't seem that this is going to happen in time.
Comment 7 Larry the Git Cow gentoo-dev 2020-09-21 06:07:26 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3bcf928002389abb44b5e5aecefcd074b8a581ad

commit 3bcf928002389abb44b5e5aecefcd074b8a581ad
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2020-09-21 06:03:02 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2020-09-21 06:07:20 +0000

    net-wireless/chirp: Remove last-rited pkg
    
    Closes: https://bugs.gentoo.org/708304
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 net-wireless/chirp/Manifest              |  1 -
 net-wireless/chirp/chirp-20200807.ebuild | 50 ----------------------------
 net-wireless/chirp/chirp-99999999.ebuild | 57 --------------------------------
 net-wireless/chirp/metadata.xml          | 15 ---------
 profiles/package.mask                    |  1 -
 5 files changed, 124 deletions(-)