Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 70820 - Cannot emerge a localized Firefox
Summary: Cannot emerge a localized Firefox
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords: InVCS
: 71838 73555 78986 117805 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-11 10:18 UTC by Alexandre Sanches
Modified: 2006-01-08 09:40 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mozilla-firefox-1.0.3.ebuild with LINGUAS support (mozilla-firefox-1.0.3.ebuild,8.45 KB, text/plain)
2005-04-17 17:48 UTC, alex f
Details
mozilla-firefox_de-DE_FIREFOX_1_0_2_RELEASE.tar.bz2 (mozilla-firefox_de-DE_FIREFOX_1_0_2_RELEASE.tar.bz2,357.38 KB, application/octet-stream)
2005-04-17 17:49 UTC, alex f
Details
mozilla-firefox_nl-NL_FIREFOX_1_0_2_RELEASE.tar.bz2 (mozilla-firefox_nl-NL_FIREFOX_1_0_2_RELEASE.tar.bz2,339.23 KB, application/octet-stream)
2005-04-17 17:50 UTC, alex f
Details
mozilla-firefox_fr-FR_FIREFOX_1_0_2_RELEASE.tar.bz2 (mozilla-firefox_fr-FR_FIREFOX_1_0_2_RELEASE.tar.bz2,766.50 KB, application/octet-stream)
2005-04-17 17:51 UTC, alex f
Details
mozilla-firefox-1.0.3.ebuild with LINGUAS support (mozilla-firefox-1.0.3.ebuild,8.41 KB, text/plain)
2005-04-20 03:31 UTC, alex f
Details
mktar.sh (mktar.sh,396 bytes, text/plain)
2005-05-24 07:26 UTC, Dick Marinus
Details
mozilla-firefox-1.0.4.ebuild (mozilla-firefox-1.0.4.ebuild,8.54 KB, text/plain)
2005-05-25 01:59 UTC, Dick Marinus
Details
mozilla-firefox-1.0.6-r5.ebuild (mozilla-firefox-1.0.6-r5.ebuild,9.85 KB, text/plain)
2005-08-17 09:52 UTC, Dick Marinus
Details
mktar.sh (mktar.sh,749 bytes, text/plain)
2005-08-17 09:53 UTC, Dick Marinus
Details
patch formozilla-firefox-1.0.6-r6.ebuild for LINGUAS (mozilla-firefox-ebuild.patch,2.50 KB, patch)
2005-08-27 11:22 UTC, ^j^
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Sanches 2004-11-11 10:18:26 UTC
Not a true problem, just a question of comfort...
Being french (sorry), I recently emerged Mozilla Firefox. Just as with Mozilla "Sea Monkey", the application is compiled in its english version, absolutely not caring about my LANG. With Mozilla there was absolutely no problem, I could, being root, go mozilla.org and install the french language pack. Today with Firefox, I see no way of doing that, so is it possible for the emerge, at compile time, to compile the program with the good language ?
As you can see, english is not my native language, but I can go with it... I am not alone

Reproducible: Always
Steps to Reproduce:
1. emerge mozilla-firefox
2. firefox
3.




Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.4.3, glibc-2.3.4.20041102-r0,
2.4.26-gentoo-r9 i686)
=================================================================
System uname: 2.4.26-gentoo-r9 i686 AMD Athlon(tm) XP 1600+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux-headers-2.4.22
Libtools: sys-devel/libtool-1.5.2-r6
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-pipe -march=athlon-xp -O3 -fomit-frame-pointer -funroll-loops"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-pipe -march=athlon-xp -O3 -fomit-frame-pointer -funroll-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://www.gigaload.org/gentoo.org/
ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://gentoo.inode.at/source/ ftp://ftp.heanet.ie/pub/gentoo/
http://ftp.heanet.ie/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex X aalib alsa apache2 apm arts avi berkdb bitmap-fonts bonobo
cddb cdr crypt cscope curl dga directfb divx4linux doc dv dvb dvd encode esd evo
f77 faad fam fbcon flac foomaticdb fortran freetds gdbm ggi gif gnome gnomedb
gnutls gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile imagemagick imlib innodb
jack java joystick jpeg junit kde ldap libcaca libg++ libgda libwww live mad
matroska mcal mikmod mmx mng motif mozilla mpeg mule mysql ncurses nls objc odbc
oggvorbis opengl oss pam pdflib perl php plotutils png postgres python qt
quicktime readline ruby samba sdl silc slang speex spell sqlite sse ssl svga
tcltk tcpd tetex theora threads tiff truetype v4l v4l2 wmf wxwindows x86 xml
xml2 xmms xosd xv xvid zlib video_cards_rage128 linguas_fr"
Comment 1 Stefan Schweizer (RETIRED) gentoo-dev 2004-11-20 06:26:48 UTC
*** Bug 71838 has been marked as a duplicate of this bug. ***
Comment 2 Davide Ferrari 2004-11-24 02:14:38 UTC
Well, the bug is another, I suppose. Firefox 1.0 for Gentoo is NOT accepting language extensions!!! I mean, you can install it but you will always get Firefox in english! With 1.0PR on Gentoo this didn't happen!
Comment 3 Dick Marinus 2004-12-16 14:57:41 UTC
s/nl-NL/fr-FR/g

I've got my firefox localized to nl-NL. You can use one of the following tricks:
First trick, install localization by xpi and change
general.useragent.locale = nl-NL in about:config

Second trick, install nl-NL.jar in /usr/lib/MozillaFirefox/chrome/
/usr/lib/MozillaFirefox/chrome/installed-chrome.txt should be altered to refer to your new nl-NL.jar
change general.useragent.locale as above.

Third trick
cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/l10n checkout -r AVIARY_1_0_20040515_BRANCH mozilla/browser/locales/nl-NL
cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/l10n checkout -r AVIARY_1_0_20040515_BRANCH mozilla/toolkit/locales/nl-NL
tar czf mozilla-locales-20041216.tar.gz mozilla
mv mozilla-locales-20041216.tar.gz /usr/portage/distfiles
edit mozilla-firefox ebuild, append mozilla-locales-20041216.tar.gz to unpack, add mozconfig_annotate '' --enable-ui-locale=nl-NL.
emerge mozilla-firefox, don't forget to remove the old ~/.mozilla or create a new profile!
Comment 4 Sebastian 2005-01-18 00:34:25 UTC
Hello! 

I made my changes to the gnome menu permanent with this (after installing the de_DE.xpi).

vi /usr/share/applications/mozillafirefox.desktop

Changed

Exec=/usr/bin/firefox %U

to

Exec=/usr/bin/firefox -contentLocale de-DE -UILocale de-DE %U

Maybe this is what you want.

Luck

Sebastian
Comment 5 Alexandre Sanches 2005-01-19 10:27:30 UTC
What I want is not relevant : I have a correct level in english and I know how to install a XPI and correct my about:config. BTW, here FF 1.0 supports language extensions, no problem...
My request is just for all those people not very fluent in english, not computer specialists. And I know a few who dare to use Gentoo !
The same bug could be reported for Mozilla the suite, Nvu, Sunbird, openoffice-bin, ...
Localization, for many people is not only "a feature". It's a must have. And I myself have no time to spend to understand Python, Portage, etc... So I only can report. In french we say "il y a ceux qui font et ceux qui font chier". I do not know how to translate that, mais l
Comment 6 Alexandre Sanches 2005-01-19 10:27:30 UTC
What I want is not relevant : I have a correct level in english and I know how to install a XPI and correct my about:config. BTW, here FF 1.0 supports language extensions, no problem...
My request is just for all those people not very fluent in english, not computer specialists. And I know a few who dare to use Gentoo !
The same bug could be reported for Mozilla the suite, Nvu, Sunbird, openoffice-bin, ...
Localization, for many people is not only "a feature". It's a must have. And I myself have no time to spend to understand Python, Portage, etc... So I only can report. In french we say "il y a ceux qui font et ceux qui font chier". I do not know how to translate that, mais lĂ  je fais chier, for sure... Sorry.
Comment 7 alex f 2005-04-17 17:47:09 UTC
The problem is that mozilla.org doesn't provide packaged locales downloads, so Gentoo has to package and distribute the locales themself (it's easy enough IMHO). I added LINGUAS support to 1.0.3 ebuild for de, nl and fr. You have to set LINGUAS="de_DE nl_NL fr_FR" to try it out. Of course you don't have to set all three of them. For creating the locales tarballs I used the relevant branchtag when checking them out from cvs. Like this (de example):

 cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/l10n export -r FIREFOX_1_0_2_RELEASE mozilla/browser/locales/de-DE

 cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/l10n export -r FIREFOX_1_0_2_RELEASE mozilla/toolkit/locales/de-DE


I'm attaching the ebuild and the three locales tarballs.
Comment 8 alex f 2005-04-17 17:48:01 UTC
Created attachment 56546 [details]
mozilla-firefox-1.0.3.ebuild with LINGUAS support
Comment 9 alex f 2005-04-17 17:49:05 UTC
Created attachment 56547 [details]
mozilla-firefox_de-DE_FIREFOX_1_0_2_RELEASE.tar.bz2
Comment 10 alex f 2005-04-17 17:50:02 UTC
Created attachment 56548 [details]
mozilla-firefox_nl-NL_FIREFOX_1_0_2_RELEASE.tar.bz2
Comment 11 alex f 2005-04-17 17:51:29 UTC
Created attachment 56549 [details]
mozilla-firefox_fr-FR_FIREFOX_1_0_2_RELEASE.tar.bz2
Comment 12 alex f 2005-04-20 03:31:55 UTC
Created attachment 56739 [details]
mozilla-firefox-1.0.3.ebuild with LINGUAS support

It seems that you cannot enable more than one locale with the
--enable-ui-locale switch. Only the last --enable-ui-locale counts. So I
modified the ebuild to build firefox with the first supported locale found in
LINGUAS.
Comment 13 Dick Marinus 2005-04-20 04:02:53 UTC
alexf I really like your ebuild!
maybe you should add a date to the translation tar.bz2's (ie. mozilla-firefox_nl-NL_FIREFOX_1_0_2_RELEASE-20050420.tar.bz2)
Comment 14 Stefan Schweizer (RETIRED) gentoo-dev 2005-04-20 06:15:46 UTC
there are language packs available for firefox:

http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0.3/linux-i686/xpi/de-DE.xpi

We should use these if we use anything. Downloading a second full source for language-support does not really make sense imo.
Comment 15 alex f 2005-04-20 06:59:10 UTC
We aren't downloading a second full source. The sources in cvs.mozilla.org:/l10n are really only the locales. The tarballs I attached here are smaller than 1 MByte. But I'll look into using the xpi packs and try to find out if the can be appled from within the ebuild.
Comment 16 alex f 2005-04-21 05:00:36 UTC
Using the locale xpi's doesn't seem to be an option. Firefox has a command line option to install xpi's globally named -install-global-extension "/path/to/extension". But using this in the ebuild does not work, since it requires a running X11 server even though it does not open any window. And even if that worked the user would still have to "activate" the locale afterwards, which is difficult given that Firefox has no UI to do so (There exists an extra extension for that).

So right now the approach to actually build the first supported locale from LINGUAS right into Firefox is much better (as my ebuild does) than installing locales as extensions.
Comment 17 alex f 2005-04-21 05:17:47 UTC
By the way, extension installation will be much simplified in Firefox 1.1. See https://bugzilla.mozilla.org/show_bug.cgi?id=286034 for details.
Comment 18 Canal Vorfeed 2005-05-22 18:04:36 UTC
Using locale's xpi is not an options by different reason: native build have more
changes, then XPI provides - that's why people want it in first place!
Additional search plugins, defalut bookmarks, it will search not only in .com,
but in .de or .jp by default, etc.

All this is not in .xpi file at all ...
Comment 19 Dick Marinus 2005-05-24 07:26:59 UTC
Created attachment 59705 [details]
mktar.sh

this stupid script creates the tarballs from CVS
Comment 20 Dick Marinus 2005-05-25 01:59:21 UTC
Created attachment 59772 [details]
mozilla-firefox-1.0.4.ebuild

version bump
Comment 21 Hanno Zysik (geki) 2005-05-25 02:15:53 UTC
just to note that there is newer localization branch here:

cvs -q -f -z4 -d:pserver:anonymous@cvs-mirror.mozilla.org:/l10n co
-rFIREFOX_1_0_3_RELEASE mozilla/browser/locales/$LINGUA
cvs -q -f -z4 -d:pserver:anonymous@cvs-mirror.mozilla.org:/l10n co
-rFIREFOX_1_0_3_RELEASE mozilla/toolkit/locales/$LINGUA

branch FIREFOX_1_0_4_RELEASE is not there.
Comment 22 Dick Marinus 2005-08-17 08:34:53 UTC
(In reply to comment #20)
> just to note that there is newer localization branch FIREFOX_1_0_3_RELEASE
> mozilla/browser/locales/$LINGUA

no there is no such branch:
http://bonsai-l10n.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=FIREFOX_1_0_3_RELEASE&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=all&mindate=&maxdate=&cvsroot=%2Fl10n

firefox translations are committed as AVIARY_1_0_20040515_BRANCH
Comment 23 Hanno Zysik (geki) 2005-08-17 09:10:03 UTC
Sorry, but there is such a branch. They do not differ. Co'ed both right now.

But ok, for you it is not there. ;)
Comment 24 Dick Marinus 2005-08-17 09:52:53 UTC
Created attachment 66147 [details]
mozilla-firefox-1.0.6-r5.ebuild

--- ../portage/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r5.ebuild      
2005-08-14 23:36:01.000000000 +0200
+++ www-client/mozilla-firefox/mozilla-firefox-1.0.6-r5.ebuild	2005-08-17
18:38:46.000000000 +0200
@@ -14,6 +14,16 @@
	http://dev.gentoo.org/~agriffis/dist/mozilla-1.7.10-nsplugins-v2.patch
	http://dev.gentoo.org/~anarchy/dist/embed-typeaheadfind.patch"

+LANGS="af_ZA ar_JO ast_ES be_BY ca_AD cs_CZ cy_GB da_DK de_DE el_GR en_GB
es_AR
+	es_ES eu_ES fi_FI fr_FR ga_IE he_IL hu_HU it_IT ja_JP ja_JPM ko_KR
lt_LT
+	mk_MK nb_NO nl_NL pa_IN pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sl_SI sq_AL

+	sv_SE tr_TR zh_CN zh_TW"
+for X in ${LANGS} ; do
+	SRC_URI="${SRC_URI} linguas_${X}? (
+	       
mirror://gentoo/${PN}_${X}_AVIARY_1_0_20040515_BRANCH-20050817.tar.bz2
+	)"
+done
+
 KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~ppc ~sparc ~x86"
 SLOT="0"
 LICENSE="MPL-1.1 NPL-1.1"
@@ -155,6 +165,13 @@
	mozconfig_use_enable mozsvg svg-renderer-cairo
	mozconfig_annotate ''
--with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
	#mozconfig_annotate '' --with-user-appdir=.firefox
+	for X in ${LANGS} ; do
+		X="${X/_/-}"
+		if [ -n "${X}" -a -d ${WORKDIR}/mozilla/browser/locales/${X} ]
; then
+			mozconfig_annotate '' --enable-ui-locale=${X}
+			break
+		fi
+	done

	# Finalize and report settings
	mozconfig_final
Comment 25 Dick Marinus 2005-08-17 09:53:56 UTC
Created attachment 66148 [details]
mktar.sh

more languages, latest version
Comment 26 ^j^ 2005-08-27 11:22:26 UTC
Created attachment 66997 [details, diff]
patch formozilla-firefox-1.0.6-r6.ebuild for LINGUAS

Please add it to Portage!!!
Comment 27 Dick Marinus 2005-08-27 12:19:24 UTC
(In reply to comment #25)
> Created an attachment (id=66997) [edit]
> patch formozilla-firefox-1.0.6-r6.ebuild for LINGUAS

Have you tried my patch? I think it is much cleaner (support for more languages)
and cvs checkout from unpack would be a really bad idea.

For the Mozilla Gentoo Team, please speak up! This shouldn't take a year!
Comment 28 Jory A. Pratt 2005-08-27 13:30:11 UTC
until I sit down and come up with a better solution best I can tell ya is to
keep up with the progress and create a custom tarball if your wanting to use
CVS. Problem with cvs is it can change from min to min as I am sure your aware
of wich makes it impossible to mark a build stable ... I will look into
snapshots that we will host on our server and use to allow LINGUAS support as
you are requesting. Later today I will also be adding the new cairo patch will
will solve a complete different bug making it much easier for you all to update
your ebuilds against. Thanks for your patients while we work out a better
solution then CVS checkouts for lingua support.
Comment 29 Hanno Zysik (geki) 2005-08-27 15:28:40 UTC
to ^j^

You add my patch! Why do you think I did not post it here yet? Like Dick Marinus
and Jory A. Pratt say. Plus there is also part of cairo patch within. See bug
#98828.


[OT] to Jory A. Pratt

Thanks to add that cairo patch finally.
Comment 30 alex f 2005-08-27 15:43:54 UTC
regarding comment #27: Jory A. Pratt we are using cvs tags, which means that no
matter when you check out, you will always get the same source.

All you have to do is set the tag in the mktag.sh script which is attached here
and distribute the generated tarballs via gentoo mirrors. please..
Comment 31 Hanno Zysik (geki) 2005-08-27 16:03:50 UTC
to Dick Marinus

I'd rather use this for language determination:

inherit eutils # which is already there, i know
strip-linguas "af_ZA ar_JO ast_ES be_BY ca_AD cs_CZ cy_GB da_DK de_DE el_GR
en_GB es_AR
	es_ES eu_ES fi_FI fr_FR ga_IE he_IL hu_HU it_IT ja_JP ja_JPM ko_KR lt_LT
	mk_MK nb_NO nl_NL pa_IN pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sl_SI sq_AL
	sv_SE tr_TR zh_CN zh_TW"

for x in ${LINGUAS}; do
	SRC_URI="${SRC_URI} linguas_${x}? (
mirror://gentoo/${PN}_${x}_AVIARY_1_0_20040515_BRANCH-20050817.tar.bz2 )"
done

But well, just another way around. :)

As i know, next Firefox/Mozilla versions will use iso codes for language naming.
So compatible to standard linguas settings like ...

ca  cs  de  el  en-GB  es-AR  eu  fi  fr  ga-IE  gu-IN  he  hu  it  ja 
ja-JP-mac   nb-NO  nl  pa-IN  pl  pl-PL  ro  ru  sl  sq  sv-SE  tr

But I do not know if all are compatible.
Comment 32 Stefan Briesenick (RETIRED) gentoo-dev 2005-08-28 03:25:14 UTC
hmmm...  
  
  if [ "x${LINGUAS}" == "x" ]; then  
      LINGUAS="en-US"  
  fi  
  
I think this is better:  
  
  [ -z "${LINGUAS}" ] && LINGUAS="en-US"  
  
just my 0.02 euro cents. ;-)  
  
nonetheless, having localized ebuilds for mozilla stuff is a must have!  
 
Comment 33 Dick Marinus 2005-08-28 04:47:11 UTC
Hanno Meyer-Thurow:
strip-linguas doesn't work right, when generating the digests (ebuild
mozilla-firefox digest) you want all languages to be downloaded and MD5ed. With
strip-linguas this doesn't work. I stole this idea from the kde-i18n.

Stefan Briesenick:
Setting the default ui-locale isn't necessary, when omitted firefox enables
en_US by default.

Alex F:
They seem to have stopped tagging since firefox 1.0.3 I've filed an bug upstream:
https://bugzilla.mozilla.org/show_bug.cgi?id=306226
Comment 34 Hanno Zysik (geki) 2005-08-28 04:56:52 UTC
Dick Marinus:

Please ignore comments to my patch silently. Thanks.
If strip-linguas does not do so it is a bug there. We should use eclass
functions, shouldn't we?!
Comment 35 alex f 2005-08-28 14:48:08 UTC
comment #32: dick, in your bugreport upstream please state why we need it. it
should be made clear, that this is important for distros in particular gentoo,
but other to i guess. i imagine then they might give it a higher priority.
Comment 36 revertex 2005-10-12 22:17:49 UTC
a pretty simple workaround could be a big EWARN at the end of compilation to
tell users that want localisation go to
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0/linux-i686/xpi/ and
install the xpi pack.
Comment 37 Jory A. Pratt 2005-10-13 13:30:35 UTC
This will be fixed when 1.5 is released for good a localized version of ff and
tb allow for locale specific to be passed and will be supported then until then
hold on as we are working to get 1.0.7 up to snuff.
Comment 38 alex f 2005-12-05 11:16:21 UTC
Firefox 1.5 is in the tree now, but contrary to comment #36 the ebuild doen't
support LINGUAS.
Comment 39 Jory A. Pratt 2005-12-05 12:06:11 UTC
I am working on this please bare with me. I plan on doing a -r1 later today that
will be added with initial code for testing only. I am not gonna guarantee it
works as I use english locale.
Comment 40 Jakub Moc (RETIRED) gentoo-dev 2005-12-22 17:59:00 UTC
*** Bug 73555 has been marked as a duplicate of this bug. ***
Comment 41 Jakub Moc (RETIRED) gentoo-dev 2005-12-22 18:13:43 UTC
*** Bug 78986 has been marked as a duplicate of this bug. ***
Comment 42 Jory A. Pratt 2005-12-25 12:05:51 UTC
Come tomorrow I will be closing this as genstef and myself have worked out the issues at hand for handling locales. So tomorrow for those of you running ~arch you will be able to have your native language support.
Comment 44 Jakub Moc (RETIRED) gentoo-dev 2006-01-04 16:36:28 UTC
*** Bug 117805 has been marked as a duplicate of this bug. ***
Comment 45 Jory A. Pratt 2006-01-08 08:35:59 UTC
I have already commited the -bin ebuild with linguas support as soon as I am done compile testing 1.5-r9 I will be adding it to the tree :)
Comment 46 Jory A. Pratt 2006-01-08 09:40:54 UTC
Fixed in CVS, thanks for your patients.